Bug#886742: postgresql-9.4-postgis-2.1 missing in stretch

Jürgen Fuchsberger juergen.fuchsberger at uni-graz.at
Tue Jan 9 13:37:44 UTC 2018

On 2018-01-09 14:16, Bas Couwenberg wrote:
> On 2018-01-09 14:08, Christoph Berg wrote:
>> Re: Juergen Fuchsberger 2018-01-09
>> <20180109130149.17725.10545.reportbug at wegc203058.uni-graz.at>
>>> Due to missing postgresql-9.4-postgis-2.1 in stretch, a postgis enabled
>>> database becomes corrupt when upgrading from jessie to stretch since
>>> the required postgis libraries are missing. This can cause serious data
>>> loss, because once upgraded to stretch, the postgis data can't be
>>> accesed nor dumped (Database gives error "could not access file
>>> "$libdir/postgis-2.1": no such file or directory").
>> Could you append the apt output to this bug? Namely, which packages
>> got removed? (/var/log/apt/term.log)
>>> Also upgrading the database to postgresql-9.6 does not work.
>> What did you try, and what didn't work?
> Probably pg_upgradecluster, and that is not supported for databases with
> the postgis extension.
Exactly. Just wanted to point out that upgrading was no possibility
either, the actual problem was that the database could not be accessed
or dumped after the upgrade.


More information about the Pkg-grass-devel mailing list