Bug#454077: maven2: maven-eclipse-plugin does not exist

Paul Cager paul-debian at home.paulcager.org
Mon Dec 3 13:53:08 UTC 2007

On Mon, December 3, 2007 01:48, Amelia A Lewis wrote:
[. . .]
> Note that the first
> attempt to invoke eclipse:eclipse used this command line (as advised
> in hudson build notes):
> mvn -o -DdownloadSources=true eclipse:eclipse
> Yes, they advise offline mode.  It appears that this may create the
> directory with inadequate stuff, because once I delete the directory
> and run the command without -o, it succeeds.
> Problem solved.

Good. I’m glad you’ve solved it.

> Thank you for your time, and please excuse my
> verbosity.  I recommend:
> 1) close this bug with no action; it resulted from wrongheaded
> directions supplied by a mavenized project over which Debian has no
> influence;
> 2) note the behavior, in case future bug reports show similar
> symptoms: if a user reports an error of this sort, suggest that they
> try deleting the "problem" directory in their repository, and that
> they verify that they're not running in offline mode (even if the
> project suggests doing so; hudson suggests mvn install and then mvn -o
> -DdownloadSources=true eclipse:eclipse, but since the
> maven-eclipse-plugin isn't installed by mvn install, the offline
> invocation appears to be the thing that stuffs up the repository
> completely).  Or, to shorten the suggestion: ask anyone reporting
> similar behavior to check the content of the directory corresponding
> to the 'not found' dependency; if it contains only *.xml without
> *.pom/*.jar (or a version subdirectory), delete the directory from the
> repo and reinvoke with all possible "offline" flags turned off.

Thanks – I’ll do that.

More information about the pkg-java-maintainers mailing list