[Pkg-libburnia-devel] Bug#800338: wodim: cant write/read using internal DVD GT34N for spesific DVD disc

Thomas Schmitt scdbackup at gmx.net
Wed Sep 30 06:29:44 UTC 2015


results for now:

- Write type "DAO" (option -sao) is not working. The attempt to write
  spoils the DVD-R medium for further writing.

- Write type "Incremental" (option -tao) for now failed only because
  it got to see the spoiled media from the -sao attempts.

Please try -tao with a fresh DVD-R medium.

Do not make further experiments with -sao. It's futile.

Details from your report:

> brianajie at heavenbox:~/tmp$ cdrskin -v dev=/dev/sr0 -sao dota1.iso
> ...
> cdrskin: FATAL : SCSI error on write(0,16): See MMC specs: Sense Key 3 "Medium error", ASC 0C ASCQ 80.

That's the same problem that can be seen in the Brasero log.

> brianajie at heavenbox:~/tmp$ cdrskin -v dev=/dev/sr0 -tao dota1.iso
> ...
> cdrskin: status 3 BURN_DISC_APPENDABLE "There is an incomplete disc in the drive"

The DVD-R is not blank any more. The "Incremental" write type
would be able to write to this medium, but the free space on
medium is much too small for taking the ISO image:

> cdrskin: FATAL : predicted session size 2294244s does not fit on media (3616s)

The burn preparations of the -sao run reserved most of
the medium capacity but then failed to fill this by data.
Now this capacity is not usable any more.

The other failures happen out of similar reasons:

> cdrskin: SORRY : Write job parameters are unsuitable
> cdrskin: Reason: SAO: write type SAO works only on blank media,

The write type on DVD-R is named "DAO", not "SAO", but elsewise
the program is right. This write type cannot work with DVD-R which
have already written data or a reserved track.

> cdrskin: FATAL : predicted session size 487500s does not fit on media (3616s)

There are only 7 MB remaining for writing on this DVD-R.
You's need to make a very small ISO so that it could fit
in there. (It would not work anyway, as we learn next.)

Then you obviously tried a new DVD-R:

The -sao run failed again with Medium Error.

The -tao run saw enough free space.
But the DVD-R is again in an unhealthy state from the previous
failed -sao run:

> Starting new track at sector: 487520
> cdrskin: FATAL : SCSI error on write(487520,16): [5 21 02] Illegal request. Invalid address for write.

The drive refused to write at the start of the unused area
of the DVD-R. Probably because the first session on the medium
is not completed.

> I tried again with the CDRW disc and DVDRW disc to makes sure
> that not drive failure and both disc works flawlessly.

So the drive is quite selectively incapable of DVD-R "DAO".

It is not clear yet whether it would do "Incremental".

Have a nice day :)


More information about the Pkg-libburnia-devel mailing list