[Pkg-nagios-devel] Bug#285550: nagios-pgsql must depends, recommends or, at least, suggest libdbd-pg-perl

RaphaŽl 'SurcouF' Bordet RaphaŽl 'SurcouF' Bordet , 285550@bugs.debian.org
Tue, 14 Dec 2004 00:24:54 +0100


Package: nagios-pgsql
Version: 2:1.3-0+pre4
Severity: important

Nagios-pgsql package doesn't have any Depends, Recommends or a Suggests
for libdbd-pg-perl package. This package is needed to use nagios with a
postgres database and check_nagios_db, as described into
/usr/share/doc/nagios-common/README.Debian.gz, chapter 4.
I suggest you must include this dependency as Depends or Recommends.

Regards,

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (900, 'testing'), (800, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.4.26-1-686-smp
Locale: LANG=fr_FR.UTF-8@euro, LC_CTYPE=fr_FR.UTF-8@euro (charmap=UTF-8)
(ignored: LC_ALL set to fr_FR.UTF-8@euro)

Versions of packages nagios-pgsql depends on:
ii  libc6                       2.3.2.ds1-18 GNU C Library: Shared
libraries an
ii  libgd2-xpm                  2.0.33-1     GD Graphics Library version
2
ii  libjpeg62                   6b-9         The Independent JPEG
Group's JPEG 
ii  libpng12-0                  1.2.8beta5-2 PNG library - runtime
ii  libpq3                      7.4.6-4      PostgreSQL C client library
ii  nagios-common               2:1.3-0+pre4 A host/service/network
monitoring 
ii  zlib1g                      1:1.2.2-3    compression library -
runtime

-- debconf information:
  nagios/warnmovedcommands:
  nagios/warncoords:
* nagios/wwwsuid: true
  nagios/newapachecfg:
  nagios/upgradefromnetsaint:
* nagios/configapache: Apache
  nagios/warnupgrade_5_6: