[Pkg-nagios-devel] Bug#497732: nagios2: External commands error messages

Glenn English ghe at slsware.com
Wed Sep 3 21:44:30 UTC 2008

Package: nagios2
Version: 2.6-2+etch1
Severity: important

I tried to enable "flap checking" in the Tactical Overview page (after
enabling external commands in the config). 

The Commit button got a "can't stat /var/.../nagios.cmd". An old thread in
a Debian list from 2006 (IIRC) said something about enabling rx
permissions on /var/lib/nagios2. I did that, and the message changed to
something about not being able to open the command for update. I changed
the permissions on the file to 777, and it worked. 

Then I noticed that the file's group owner was nagios. Changing this to
www-data allowed me to reset the permissions to 770.

I hope this is useful info -- I've never used reportbug before.

Bottom line: there's likely a directory permissions problem, and there's
definitely a file ownership problem in /var/lib/nagios2/rw/nagios.cmd.

I think...

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-6-486
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages nagios2 depends on:
ii  libc6                  2.3.6.ds1-13etch7 GNU C Library: Shared libraries
ii  libgd2-noxpm           2.0.33-5.2etch1   GD Graphics Library version 2 (wit
ii  libjpeg62              6b-13             The Independent JPEG Group's JPEG 
ii  libperl5.8             5.8.8-7etch3      Shared Perl library
ii  libpng12-0             1.2.15~beta5-1    PNG library - runtime
ii  nagios2-common         2.6-2+etch1       support files for nagios2
ii  perl                   5.8.8-7etch3      Larry Wall's Practical Extraction 
ii  zlib1g                 1:1.2.3-13        compression library - runtime

nagios2 recommends no packages.

-- no debconf information

More information about the Pkg-nagios-devel mailing list