[Pkg-nagios-devel] Bug#497732: Bug#497732: nagios2: External commands error messages

Alexander Wirt formorer at debian.org
Thu Sep 4 04:50:30 UTC 2008

tags 497732 wontfix

Glenn English schrieb am Wednesday, den 03. September 2008:

> Package: nagios2
> Version: 2.6-2+etch1
> Severity: important
> I tried to enable "flap checking" in the Tactical Overview page (after
> enabling external commands in the config). 
> The Commit button got a "can't stat /var/.../nagios.cmd". An old thread in
> a Debian list from 2006 (IIRC) said something about enabling rx
> permissions on /var/lib/nagios2. I did that, and the message changed to
> something about not being able to open the command for update. I changed
> the permissions on the file to 777, and it worked. 
> Then I noticed that the file's group owner was nagios. Changing this to
> www-data allowed me to reset the permissions to 770.
> I hope this is useful info -- I've never used reportbug before.
> Bottom line: there's likely a directory permissions problem, and there's
> definitely a file ownership problem in /var/lib/nagios2/rw/nagios.cmd.
> I think...
Please read README.Debian. Its explained there why and how to change the


More information about the Pkg-nagios-devel mailing list