thinking of use latest nvidia on wheezy

Ross Boylan rossboylan at
Sat Jan 2 05:38:25 UTC 2016

My screen is now blank, even in the alternate, textual VT's.  The
problem with the text VT's was happening before I installed the nvidia
drivers, and so may be separate.

After building a bunch of packages and dpkg -i them, on reboot Xorg.log shows
[   126.926] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   127.031] Parse error on line 7 of section OutputClass in file
        "OutputClass" is not a valid section name.
[   127.031] (EE) Problem parsing the config file
[   127.031] (EE) Error parsing the config file
[   127.032]
Fatal server error:

The full text of that conf file is
# This xorg.conf.d configuration snippet configures the X server to
# automatically load the nvidia driver when it detects a device driven by the
# nvidia.ko kernel module.  Please note that this only works on Linux kernels
# version 3.9 or higher with CONFIG_DRM enabled, and only if the nvidia.ko
# kernel module is loaded before the X server is started.

Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"

So it needs a newer X (I guess) and a newer kernel than I'm running.
I see 3.16 is available from backports, but that still wouldn't take
care of the X.

Ideas?  Maybe if I took more of the packages from older versions,
i.e., backports for wheezy, things would work better.

Partly because the apt-get source from experimental wasn't working, I
downloaded the packages directly, did dpkg-source -x to unpack, and
dpkg-buildpackage to build them.  Then I used dpkg -i to install, and
iterated as I dicovered dependencies.

I got sources for
glx-alternatives_0.7.1.dsc  nvidia-graphics-drivers_352.63-1.dsc
libvdpau_1.1.1-3.dsc        nvidia-settings_346.59-1.dsc
though nvidia-settings had build dependencies that prevented me from building.

I ended up with
dpkg -i \
     nvidia-installer-cleanup_20151021+1_amd64.deb \
     glx-diversions_0.7.1_amd64.deb \
     glx-alternative-mesa_0.7.1_amd64.deb \
     update-glx_0.7.1_amd64.deb \
     glx-alternative-nvidia_0.7.1_amd64.deb \
     nvidia-kernel-common_20151021+1_amd64.deb \
     nvidia-support_20151021+1_amd64.deb \
 nvidia-kernel-support_352.63-1_amd64.deb \
 nvidia-kernel-dkms_352.63-1_amd64.deb \
 libnvidia-ml1_352.63-1_amd64.deb \
  libcuda1_352.63-1_amd64.deb \
 libegl1-nvidia_352.63-1_amd64.deb \
 libnvidia-eglcore_352.63-1_amd64.deb \
 libgl1-nvidia-glx_352.63-1_amd64.deb \
 nvidia-driver_352.63-1_amd64.deb \
 nvidia-driver-bin_352.63-1_amd64.deb \
 xserver-xorg-video-nvidia_352.63-1_amd64.deb \
     libvdpau1_1.1.1-3_amd64.deb \
 nvidia-vdpau-driver_352.63-1_amd64.deb \
 nvidia-alternative_352.63-1_amd64.deb \
 libgles1-nvidia_352.63-1_amd64.deb \
 libgles2-nvidia_352.63-1_amd64.deb \

Plus a few packages installed via aptitude, generally from backports.

On Fri, Jan 1, 2016 at 2:50 PM, Ross Boylan
<rossboylan at> wrote:
> Thanks very much.  I guess the easiest thing is to try building the
> experimental packages on wheezy.
> I guess I'll have to get the packages somewhat manually, since
> $ apt-get source -t experimental glx-alternative-nvidia
> Reading package lists... Done
> E: The value 'experimental' is invalid for APT::Default-Release as
> such a release is not available in the sources
> This is after adding
> deb-src experimental main contrib non-free
> to sources.list, doing aptitude update, which showed the indices being
> retrieved, and then doing apt-get update in case that was needed.
> aptitude update showed
> Get: 1 experimental/main Sources/DiffIndex [27.8 kB]
> Ign wheezy/non-free Translation-en_US
> Ign wheezy/non-free Translation-en
> Get: 2 experimental/contrib Sources/DiffIndex [1,195 B]
> Get: 3 experimental/non-free
> Sources/DiffIndex [1,885 B]
> Fetched 30.9 kB in 6s (4,974 B/s)
> Also, since the packages aren't installed, and wouldn't be the right
> version anyway, I'll check the control files manually for build-deps.
> Ross
> P.S. A couple of attempts at booting a wheezy system with the monitor
> but without any special nvidia  packages  produced only a blank
> screen.  Is that to be expected?  I'm having trouble getting the
> alternate system booting working, and so the problem might be there
> instead.
> On Fri, Jan 1, 2016 at 4:49 AM, Luca Boccassi <luca.boccassi at> wrote:
>> On 31 December 2015 at 22:01, Ross Boylan <rossboylan at> wrote:
>>> Hi, nvidia packagers.  Thanks for your work, and happy new year.
>>> I have a 980 Ti that I would like to use at a higher resolution than
>>> 1024x768.  My amd64 system is running wheezy.  Any tips on getting
>>> this to work?  If it won't work, that would be a useful tip too.
>>> I was thinking of combing the latest sources from nvidia, which seem
>>> to be 352.63,* with the Debian packaging.  I see on
>>> that getting
>>> things working even on jessie has been difficult.
>>> I'm also unclear where the project repository is.
>>> and
>>> messages on this list suggest it's in subversion, but
>>> indicates using git.
>>> I'm not a DD, and only want read access.
>>> I suppose I could just execute the installer from nvidia, but then I'd
>>> have no control over what it did and, I suspect, no reliable way to
>>> back it out.
>>> Ross Boylan
>>> * Though I notice branches for 355 and 358 in the repo.
>> Hello Ross,
>> Happy new year!
>> First of all, wheezy is oldstable now, so I would really recommend
>> upgrading to jessie if possible, as it would make your life so much
>> easier.
>> I haven't personally tried to backport 352 to wheezy, so no
>> guarantees. And it goes without saying that it's all unsupported and
>> might light your keyboard on fire etc etc :-)
>> Once 352 moves out of experimental, it just might end up being
>> uploaded to wheezy-backports too eventually, but no promises, and most
>> importantly no timeline.
>> The nvidia-graphics-driver source is in SVN:
>> But I would not recommend building sources from the repository, as it
>> might contain unreleased and potentially unstable changes. Instead,
>> it's safer to build the sources from experimental since they are tried
>> and tested.
>> If you add the deb-src for experimental to your sources, you can
>> simply do (warning, I'm away from my dev machines so I'm writing from
>> memory, might need tweaking):
>> sudo apt-get build-dep nvidia-driver glx-alternative-nvidia
>> apt-get source -b -t experimental glx-alternative-nvidia
>> apt-get source -b -t experimental nvidia-driver
>> The only dependency that needs backporting should be the
>> glx-alternative packages, everything else should be fine in theory, if
>> memory serves.
>> Alternatively from adding deb-src, you can simply manually download
>> the tarballs (both .orig and .debian) for those 2 sources separately
>> from, untar and use: debuild -uc -us to manually
>> build. The build-dep stage is necessary in both cases.
>> Good luck :-)
>> Kind regards,
>> Luca Boccassi

More information about the pkg-nvidia-devel mailing list