Bug#909218: nvidia-xconfig: Files section missing ModulePath entries break GLX upon installing libgl1-nvidia-glx (required by Steam)

miguev miguev at gmail.com
Wed Sep 19 21:26:42 BST 2018

Package: nvidia-xconfig
Version: 390.25-1
Severity: important
Tags: patch

Dear Maintainer,

Apologies if this (my first) bug report is inappropriate, I'll be happy to file
better ones if necessary.

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

A rather convoluted sequence of operations:

1. Install NVidia drivers

Add the contrib and non-free packages:
# vi /etc/apt/sources.list
deb http://ftp.ch.debian.org/debian/ testing main contrib non-free
# apt update
# apt dist-upgrade
# apt install nvidia-driver vulkan-utils nvidia-smi nvidia-xconfig

2. System freezes after locking screen with xflock4, can't even get to tty.
Workaround is to generate /etc/X11/xorg.conf by running nvidia-xconfig
# nvidia-xconfig
# /etc/init.d/lightdm restart

3. Install Steam

Download steam_1.0.0.56-1_i386.deb from
Download libgl1_1.1.0-1_i386.deb from https://packages.debian.org/buster/libgl1
# wget http://ftp.ch.debian.org/debian/pool/non-
# dpkg --add-architecture i386
# apt update
# dpkg -i steam_1.0.0.56-1_i386.deb libgl1_1.1.0-1_i386.deb
# apt -f install

Steam fails with:

You are missing the following 32-bit libraries, and Steam may not run:
Press enter to continue:

At this point, glxinfo and glxgears work fine.

4. Install NVidia 32-bit GLX libraries:

# apt install libgl1-nvidia-glx
The following packages will be REMOVED:
  libgl1-nvidia-glvnd-glx nvidia-driver-libs nvidia-vulkan-common nvidia-

At this point, glxinfo and glxgears fail (even before restaring X) with:

name of display: :0.0
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  155 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x3a00003
  Serial number of failed request:  35
  Current serial number in output stream:  35

The same error is encountered when trying to run Steam. Workarounds in
did not help because, as I would only find later, glxinfo & glxgears were

Upon restaring X the following errors are found in /var/log/Xorg.0.log
[   817.427] (EE) NVIDIA(0): Failed to initialize the GLX module; please check
in your X
[   817.427] (EE) NVIDIA(0):     log file that the GLX module has been loaded
in your X
[   817.427] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX
module.  If
[   817.427] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[   817.427] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.

   * What exactly did you do (or not do) that was effective (or

Adding NVidia’s drivers path in /etc/X11/xorg.conf in the otherwise empty
“Files” section:
Section "Files"
    ModulePath     "/usr/lib/nvidia"
    ModulePath     "/usr/lib/xorg/modules"

The paths are those that contain libglx.so
# find /usr/ -name libglx.so

Found this idea in the NVidia Dveloper forum:

   * What was the outcome of this action?

After restarting X, glxinfo and glxgears worked fine again, and so does Steam.

   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.18.0-1-amd64 (SMP w/12 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages nvidia-xconfig depends on:
ii  libc6                     2.27-6
ii  nvidia-installer-cleanup  20151021+8

Versions of packages nvidia-xconfig recommends:
ii  libgl1-nvidia-glx [libgl1-nvidia-glx-any]  390.77-1

nvidia-xconfig suggests no packages.

-- no debconf information

More information about the pkg-nvidia-devel mailing list