Bug#903121: Your mail

J.P. Lien jolien at vt.edu
Fri Sep 28 03:41:05 BST 2018

So I just ran into a similar issue on my system (desktop with a GTX 
1060).  The problem in my case was that X was trying to load the X.ORG 
version of GLX from


I worked around it by replacing this with a symlink to the nvidia lib in


Not sure how this is supposed to work or resolve to the correct driver 
since I don't have another system to compare to.  I think it's maybe 
related to a broader problem with alternatives and glvnd because after 
reinstalling the nvidia driver from scratch multiple times I was still 
getting MESA until I switched to the non-glvnd variant.

J.P. Lien

On Thu, 30 Aug 2018 14:22:02 +0200 Philipp Baumgart <pb at xattr.net> wrote:
> I did not encounter this bug or any other related problem on my system.
> System type: Desktop PC
> Gfx: Nvidia GTX 10170
> CPU: AMD Ryzen 2700
> Kernel: 4.17.0-3-amd64 #1 SMP Debian 4.17.17-1 (2018-08-18) x86_64 GNU/Linux
> Nvidia Driver: nvidia-graphics-drivers 390.77-1
> Even the problem described in 
> https://lists.debian.org/debian-user/2018/07/msg00059.html is solved.
> Maybe its only Laptop related. The bug reporter should give an update if 
> the issue still exists.

More information about the pkg-nvidia-devel mailing list