Bug#909218: nvidia-xconfig: Files section missing ModulePath entries break GLX upon installing libgl1-nvidia-glx (required by Steam)

Andreas Beckmann anbe at debian.org
Sun Sep 30 14:03:26 BST 2018

On 2018-09-30 09:31, Miguel Angel Vilela wrote:
> Apologies for the long time it took me to get back to you, as well as for
> probably having file the wrong bug entirely.
> I run the following commands on TTY1 and gather the logs. After starting X
> with no Xorg.conf I logged in and tried locking the screen again to confirm
> the bug reproduces and indeed it did, but the sleep+stop trick let me out:
> # /etc/init.d/lightdm stop
> # cd /etc/X11/
> # mv xorg.conf xorg.conf.nvidia-xconfig
> # vi xorg.conf
> # cat xorg.conf
> Section "Files"
>     ModulePath     "/usr/lib/xorg/modules/linux"
>     ModulePath     "/usr/lib/xorg/modules"
> EndSection
> Section "Device"
>     Identifier     "Device0"
>     Driver         "nvidia"
> EndSection

Thanks for the logfiles. Could you try another thing: Does the minimal
xorg.conf still work if you remove the Files section?

>From the logfiles I can only conclude that Xorg should end up in the
same state in both cases ... having loaded and unloaded a few more
modules should not make a difference. Maybe we have to blame Xorg in
this case.

Looks like from driver 410.xx onwards we no longer have to fiddle with
the ModulePath anyway, since nvidia renamed the libglx.so module to
something without a conflicting name.


More information about the pkg-nvidia-devel mailing list