[pkg-php-pear] Bug#813125: php-proxy-manager 2.0.0* has a dependency on a new PHP API PackageVersions

Nishanth Aravamudan nish.aravamudan at canonical.com
Fri Jan 29 16:39:13 UTC 2016

Package: php-proxy-manager
Version: 2.0.0-*
Severity: serious
Justification: fails to build from source (but built successfully in the past)

Dear Maintainer,

While updating the packages in an Ubuntu Xenial PPA to use PHP7.0 by
default, I ran into phpunit failures with the php-proxy-manager package.
The same issues should be seen with Debian unstable.

I see that per https://packages.qa.debian.org/p/php-proxy-manager.html,
there is a 2.0.0~beta1 available to package. Per
https://github.com/Ocramius/ProxyManager/issues/286, that version will
be released officially soon, but it has a dependency that prevents it
from successfully packaging currently. The upstream code has introduced
a new dependency on https://github.com/Ocramius/PackageVersions, which I
am guessing would need to be packaged as a new package, i.e.,

Note that the new version of php-proxy-manager also depends on
php-zend-code >= 3.0, which is currently only available in

Nishanth Aravamudan
Ubuntu Server
Canonical Ltd

More information about the pkg-php-pear mailing list