Bug#768824: pulseaudio: DISALLOW_MODULE_LOADING which is set in /etc/default/pulseaudio is overriden in /etc/init.d/pulseaudio

Juan Díaz Porras alkayata2001 at gmail.com
Sun Nov 9 14:22:53 UTC 2014

Package: pulseaudio
Version: 2.0-6.1
Severity: important
Tags: d-i

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
 On a two user machine with two soundcards - onboard and usb - sound sometimes
stops working after user switching. Also pulseaudio doesn't yield usb card
control to jackd server when I try to start it. It seems that if
DISALLOW_MODULE_LOADING is set to 1, then module-udev-detect and module-
jackdbus-detect won't load causing that behaviour.
   * What exactly did you do (or not do) that was effective (or
 Once I realized DISALLOW_MODULE_LOADING was set twice, one in
/etc/default/pulseaudio and other in /etc/init.d/pulseaudio I tried firts
'dpkg-reconfigure pulseaudio' but it did'nt nothing. Then I change by hand the
value of DISALLOW_MODULE_LOADING in the two files to 0.
   * What was the outcome of this action?
 When I tried 'dpkg-reconfigure pulseaudio' It only warned me that pulseaudio
was configured as per user session.
 Changing both DISALLOW_MODULE_LOADING assignementsto 0 seemed to work fine by
   * What outcome did you expect instead?
 I expected that 'dpkg-reconfigure pulseaudio' had done that work for me, I
find the warning message "Pulseaudio is configured as per user session"
annoying and useless. It warns me also each time pulseaudio starts, but I don't
understand why, since according to website is the right way to configure, and
it is what I want.
 I expected also to have only one assignement of DISALLOW_MODULE_LOADING in
/etc/default/pulseaudio. I find confusing having the overriding one in

-- System Information:
Debian Release: 7.7
  APT prefers stable
  APT policy: (800, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=es_ES.UTF-8, LC_CTYPE=es_ES.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages pulseaudio depends on:
ii  adduser                       3.113+nmu3
ii  consolekit                    0.4.5-3.1
ii  libasound2                    1.0.25-4
ii  libasound2-plugins            1.0.25-2
ii  libc6                         2.13-38+deb7u6
ii  libcap2                       1:2.22-1.2
ii  libdbus-1-3                   1.6.8-1+deb7u4
ii  libfftw3-3                    3.3.2-3.1
ii  libgcc1                       1:4.7.2-5
ii  libice6                       2:1.0.8-2
ii  libltdl7                      2.4.2-1.1
ii  liborc-0.4-0                  1:0.4.16-2
ii  libpulse0                     2.0-6.1
ii  libsamplerate0                0.1.8-5
ii  libsm6                        2:1.2.1-2
ii  libsndfile1                   1.0.25-5
ii  libspeexdsp1                  1.2~rc1-7
ii  libstdc++6                    4.7.2-5
ii  libsystemd-daemon0            44-11+deb7u4
ii  libsystemd-login0             44-11+deb7u4
ii  libtdb1                       1.2.10-2
ii  libudev0                      175-7.2
ii  libwebrtc-audio-processing-0  0.1-2
ii  libx11-6                      2:1.5.0-1+deb7u1
ii  libx11-xcb1                   2:1.5.0-1+deb7u1
ii  libxcb1                       1.8.1-2+deb7u1
ii  libxtst6                      2:1.2.1-1+deb7u1
ii  lsb-base                      4.1+Debian8+deb7u1
ii  udev                          175-7.2

Versions of packages pulseaudio recommends:
ii  gstreamer0.10-pulseaudio  0.10.31-3+nmu1
ii  pulseaudio-module-x11     2.0-6.1
ii  rtkit                     0.10-2+wheezy1

Versions of packages pulseaudio suggests:
ii  paman             0.9.4-1
ii  paprefs           0.9.10-1
ii  pavucontrol       1.0-1
ii  pavumeter         0.9.3-4
ii  pulseaudio-utils  2.0-6.1

-- Configuration Files:
/etc/default/pulseaudio changed:

/etc/init.d/pulseaudio changed:
test -x $DAEMON || exit 0
.. /lib/lsb/init-functions
test -f /etc/default/pulseaudio && . /etc/default/pulseaudio
if [ "$PULSEAUDIO_SYSTEM_START" != "1" ]; then
	log_warning_msg "PulseAudio configured for per-user sessions"
	exit 0
pulseaudio_start () {
	log_daemon_msg "Starting system PulseAudio Daemon"
	if [ ! -d $PIDDIR ]; then
		mkdir -p $PIDDIR
	start-stop-daemon -x $DAEMON -p $PIDFILE --start -- --system --disallow-exit --disallow-module-loading=$DISALLOW_MODULE_LOADING --daemonize --log-target=syslog --high-priority
	if [ -e /var/run/pulse/.esd_auth ]; then
		chown pulse:pulse-access /var/run/pulse/.esd_auth
		chmod 640 /var/run/pulse/.esd_auth
	if [ -e /var/run/pulse/.pulse-cookie ]; then
		chown pulse:pulse-access /var/run/pulse/.pulse-cookie
		chmod 640 /var/run/pulse/.pulse-cookie
	log_end_msg ${status}
pulseaudio_stop () {
	log_daemon_msg "Stopping system PulseAudio Daemon"
	start-stop-daemon -p $PIDFILE --stop --retry 5 || echo -n "...which is not running"
	log_end_msg $?
case "$1" in
		if [ -s $PIDFILE ] && kill -0 $(cat $PIDFILE) >/dev/null 2>&1; then
		killall pulseaudio || true
		sleep 2
		killall -9 pulseaudio || true
		status_of_proc -p $PIDFILE "$DAEMON" "system-wide PulseAudio" && exit 0 || exit $?
		echo "Usage: /etc/init.d/pulseaudio {start|stop|force-stop|restart|reload|force-reload|status}"
		exit 1
exit 0

/etc/pulse/default.pa changed:
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
..ifexists module-udev-detect.so
load-module module-udev-detect
load-module module-detect
..ifexists module-jackdbus-detect.so
load-module module-jackdbus-detect
..ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
..ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
load-module module-native-protocol-unix
..ifexists module-gconf.so
load-module module-gconf
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
..ifexists module-console-kit.so
load-module module-console-kit
..ifexists module-systemd-login.so
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
..ifexists module-dbus-protocol.so
load-module module-dbus-protocol
load-module module-switch-on-port-available
set-default-sink UA-25EX
set-default-source UA-25EX

-- no debconf information

More information about the pkg-pulseaudio-devel mailing list