Bug#768824: pulseaudio: DISALLOW_MODULE_LOADING which is set in /etc/default/pulseaudio is overriden in /etc/init.d/pulseaudio

Felipe Sateler fsateler at debian.org
Mon Nov 10 00:38:21 UTC 2014

Control: tags -1 moreinfo
Control: severity -1 normal

On Sun, Nov 9, 2014 at 11:22 AM, Juan Díaz Porras
<alkayata2001 at gmail.com> wrote:
> Package: pulseaudio
> Version: 2.0-6.1
> Severity: important
> Tags: d-i
> Dear Maintainer,
> *** Please consider answering these questions, where appropriate ***
>    * What led up to the situation?
>  On a two user machine with two soundcards - onboard and usb - sound sometimes
> stops working after user switching. Also pulseaudio doesn't yield usb card
> control to jackd server when I try to start it. It seems that if
> DISALLOW_MODULE_LOADING is set to 1, then module-udev-detect and module-
> jackdbus-detect won't load causing that behaviour.
>    * What exactly did you do (or not do) that was ffective (or
>      ineffective)?
>  Once I realized DISALLOW_MODULE_LOADING was set twice, one in
> /etc/default/pulseaudio and other in /etc/init.d/pulseaudio I tried firts
> 'dpkg-reconfigure pulseaudio' but it did'nt nothing. Then I change by hand the
> value of DISALLOW_MODULE_LOADING in the two files to 0.
>    * What was the outcome of this action?
>  When I tried 'dpkg-reconfigure pulseaudio' It only warned me that pulseaudio
> was configured as per user session.
>  Changing both DISALLOW_MODULE_LOADING assignementsto 0 seemed to work fine by
> now.
>    * What outcome did you expect instead?
>  I expected that 'dpkg-reconfigure pulseaudio' had done that work for me, I
> find the warning message "Pulseaudio is configured as per user session"
> annoying and useless. It warns me also each time pulseaudio starts, but I don't
> understand why, since according to website is the right way to configure, and
> it is what I want.
>  I expected also to have only one assignement of DISALLOW_MODULE_LOADING in
> /etc/default/pulseaudio. I find confusing having the overriding one in
> /etc/init.d/pulseaudio.

I am unclear as to what the bug actually is.

The files show you do not have systemwide pulseaudio enabled, so
whatever you do on /etc/default/pulseaudio will not affect your
running pulseaudio instance, as that will be started by your user
processes, and will not actually be started by /etc/init.d/pulseaudio

Reducing severity since system instances are discouraged (and indeed
in jessie it is not supported by default).


Felipe Sateler

More information about the pkg-pulseaudio-devel mailing list