[Pkg-samba-maint] Bug#620818: Bug#620818: mount.cifs appends trailing slash to share name in kernel

Luk Claes luk at debian.org
Mon Apr 4 12:47:10 UTC 2011

On 04/04/2011 01:55 PM, Jan Engelhardt wrote:
> Package: cifs-utils
> Version: 4.9

That's not a version in Debian, I guess you mean 2:4.9-1? Can you give
the output from 'apt-cache policy cifs-utils' so we can confirm?

> Bug #586009 has essentially not been solved. Fixing mtab won't help when 
> you run systems with /etc/mtab as a symlink to /proc/self/mounts.

Any reason why you open a new bug in that case?

> # strace -fe mount -s 65536 -v mount -t cifs //localhost/homes /mnt -o user=root
> [pid  2734] mount("//localhost/homes/", ".", "cifs", 0, "ip=::1,unc=\\\\localhost\\homes,,ver=1,user=root,pass=abc") = 0
> # tail -n1 /proc/self/mounts
> //localhost/homes/ /mnt cifs rw,relatime,unc=\\localhost\homes,username=root,uid=0,noforceuid,gid=0,noforcegid,addr=0000:0000:0000:0000:0000:0000:0000:0001,posixpaths,serverino,acl,rsize=16384,wsize=57344,actimeo=1 0 0

This is an observation, though I don't see any mention of what problem
it causes for you especially as you are being root when doing the mount.

If you think user unmounts are still not working, can you please add the
appropriate fstab entry and show the commands you execute together with
their output?

Thanks in advance.


PS: There exists a reportbug tool that eases opening/handling of bugs by

More information about the Pkg-samba-maint mailing list