[Pkg-samba-maint] Bug#620818: Bug#620818: mount.cifs appends trailing slash to share name in kernel

Jan Engelhardt jengelh at medozas.de
Mon Apr 4 13:06:26 UTC 2011

On Monday 2011-04-04 14:47, Luk Claes wrote:
>On 04/04/2011 01:55 PM, Jan Engelhardt wrote:
>> Package: cifs-utils
>> Version: 4.9
>That's not a version in Debian, I guess you mean 2:4.9-1? Can you give
>the output from 'apt-cache policy cifs-utils' so we can confirm?

I don't actually run Debian, though I monitor DBTS for bugs against 
upstream packages, such as pam_mount, that I maintain. I suspect that, 
since the bug is reproducible on openSUSE too, that it is a general 
issue. Appending new findings to the Debian issue stream seems like the 
best way to record the persistence of problems.

>> Bug #586009 has essentially not been solved. Fixing mtab won't help when 
>> you run systems with /etc/mtab as a symlink to /proc/self/mounts.
>Any reason why you open a new bug in that case?

DBTS tends to.. reject mail some time in the future after a bug has been 

>> # strace -fe mount -s 65536 -v mount -t cifs //localhost/homes /mnt -o user=root
>> [pid  2734] mount("//localhost/homes/", ".", "cifs", 0, "ip=::1,unc=\\\\localhost\\homes,,ver=1,user=root,pass=abc") = 0
>> # tail -n1 /proc/self/mounts
>> //localhost/homes/ /mnt cifs rw,relatime,unc=\\localhost\homes,username=root,uid=0,noforceuid,gid=0,noforcegid,addr=0000:0000:0000:0000:0000:0000:0000:0001,posixpaths,serverino,acl,rsize=16384,wsize=57344,actimeo=1 0 0
>This is an observation, though I don't see any mention of what problem
>it causes for you especially as you are being root when doing the mount.

The problem occurs when one tries to compare whether something has been 
mounted already. In pam_mount.conf.xml, someone may specify 
"//localhost/homes" to be mounted. This then gets mounted on login, 
however, on second login, it may be erroneously tried to be mounted 
again, because "//localhost/homes/" (procfs) != "//localhost/homes" 

More information about the Pkg-samba-maint mailing list