[Pkg-samba-maint] Bug#774328: Bug#774328: ctdb: Failed to start ctdb.service: Unit ctdb.service failed to load: No such file or directory.

Martin Schwenke martin at meltin.net
Wed Jan 28 00:07:04 UTC 2015

Hi Mathieu,

This has stopped failing.  While that's obviously excellent, I wish I
could explain it.  :-(

Perhaps a systemd update did something magic?  I've only just seen
Cameron Norman's suggestion from 2015-01-02 to try "systemctl
daemon-reload".  That would have been a nice idea.  Not sure why I
didn't get an email from the bug system for Cameron's comment.  :-(
This was happening on my laptop where reboots are uncommon... so I
suppose a reboot could have fixed it too.

Do packages that provide systemd init need to set some sort of trigger
that causes a "systemctl daemon-reload"?  I just tried installing
proftpd-basic (random choice of daemon that I've never had installed
before), it starts and stops fine and I can't find any evidence of a
trigger like that, so that theory seems bogus.  :-(

Answers to questions below...

On Tue, 27 Jan 2015 14:51:46 +0100, Mathieu Parent
<math.parent at gmail.com> wrote:

> 2015-01-16 9:20 GMT+01:00 Martin Schwenke <martin at meltin.net>:

> >> Anything relevant in /var/log/{syslog,ctdb/log.ctdb}? journalctl -u
> >> ctdb.service?
> >
> > No, nothing at all.  It looks like it is failing somewhere in systemd.
> It's /var/log/ctdb/log.ctdb. Have you checked it too?

Yes, I had checked it and it was always empty, unless I ran
ctdbd_wrapper directly.  That's why I assumed a systemd problem.

Now it logs the expected failure due to broken configuration.  I'm
happy with that because I know enough if I want to configure CTDB from
this point...  :-)

> What "journalctl --unit ctdb.service" says ?
> Is there any red line in "systemctl list-units"?

Yeah, given that it now works I see the CTDB-specific failure.

Sorry that this was a waste of time and we couldn't work out why it was
happening.  :-(

peace & happiness,

More information about the Pkg-samba-maint mailing list