[Pkg-samba-maint] Bug#774328: Bug#774328: ctdb: Failed to start ctdb.service: Unit ctdb.service failed to load: No such file or directory.

Mathieu Parent math.parent at gmail.com
Wed Jan 28 14:37:57 UTC 2015


Some background for systemd maintainers: ctdb was failing to start
with a "no such file or drectory" error after an upgrade from wheezy
to jessie.

2015-01-28 1:07 GMT+01:00 Martin Schwenke <martin at meltin.net>:
> Hi Mathieu,
> This has stopped failing.  While that's obviously excellent, I wish I
> could explain it.  :-(


> Perhaps a systemd update did something magic?  I've only just seen
> Cameron Norman's suggestion from 2015-01-02 to try "systemctl
> daemon-reload".  That would have been a nice idea.  Not sure why I
> didn't get an email from the bug system for Cameron's comment.  :-(
> This was happening on my laptop where reboots are uncommon... so I
> suppose a reboot could have fixed it too.

Yes.I guess.

> Do packages that provide systemd init need to set some sort of trigger
> that causes a "systemctl daemon-reload"?  I just tried installing
> proftpd-basic (random choice of daemon that I've never had installed
> before), it starts and stops fine and I can't find any evidence of a
> trigger like that, so that theory seems bogus.  :-(

"systemctl --system daemon-reload" is in ctdb postrm but not in
postinst (from debhelper).

Asking to the systemd maintainers:
Is this a known problem? Is this coming from ctdb being an init file
before, and a ".service" now?

> Answers to questions below...
thanks for your answers.



More information about the Pkg-samba-maint mailing list