[Pkg-systemd-maintainers] gdm3: GLib.js still an issue GDM doesn't get to greeter

Emilio Pozuelo Monfort pochu at debian.org
Mon Nov 18 18:29:44 GMT 2013

retitle 729674 libpam-systemd: wrong runtime_dir when changing uid
reassign 729674 libpam-systemd
affects 729674 gdm3
# this causes gdm3 to fail to start in certain scenarios
severity 729674 serious
forwarded 729674 https://bugs.freedesktop.org/show_bug.cgi?id=70810

On 17/11/13 19:28, Emilio Pozuelo Monfort wrote:
> On 17/11/13 19:01, Emilio Pozuelo Monfort wrote:
>> On 17/11/13 17:51, Les Schaffer wrote:
>>> On 11/17/2013 11:22 AM, Emilio Pozuelo Monfort wrote:
>>>> I see you're running linux 3.12. Where have you got it from? Have you built it
>>>> yourself? Was CONFIG_CGROUPS disabled when building it? Do other
>>>> /proc/$pid/cgroup files exist?
>>> 3.12 is my own, i believe CONFIG_CGROUPS is disabled, yes. to save you
>>> grief i tried debian unstable's very own 3.11-1 and get similar problem
>>> but different issue in :0-greeter.log, billions and billions of:
>> Ok so CONFIG_CGROUPS being disabled is the problem here.

That is now #729877. Let's track the /run/user/0 problem here.

>>> (gnome-settings-daemon:4938): dconf-CRITICAL **: unable to create
>>> directory '/run/user/0/dconf': Permission denied.  dconf will not work
>>> properly.
>>> i think you solved this earlier???????
>> No, we got this reported in #724731 but it was mixed with the other two bugs
>> there so it got kind of lost. This may be related to
>> https://bugs.freedesktop.org/show_bug.cgi?id=70810
> Or it may be:
> https://bugzilla.redhat.com/show_bug.cgi?id=753882
> see comment 57 onwards.
> This has been forwarded upstream:
> http://lists.freedesktop.org/archives/systemd-devel/2013-November/014370.html
> In any case I don't understand why some users hit this in gdm3 while others don't...

This is (arguably) a libpam-systemd bug, see the fdo and redhat bug reports and
the thread in systemd-devel. Reassigning. Bumping severity as this causes gdm3
to not start for a few users, though I haven't fully understood how gdm is being
started as to be affected by this... Note that this can also affect other stuff
when users get a su session or similar and run some commands, e.g. pulseaudio
can stop working, see https://launchpad.net/bugs/1197395

Can we have Martin's patch? Les, can you test that systemd patch and confirm it
fixes the problem? I can build amd64 packages if you need them.

I'd still like to understand under what circumstances gdm is affected.


> When you've got that permission denied error, how did you start gdm3? Did it
> start after a reboot or did you start it from a tty?
> If you set gdm3 as your display manager to start on boot and reboot with linux
> 3.11, do you still get a blank screen?
> Emilio

More information about the Pkg-systemd-maintainers mailing list