[pkg-uWSGI-devel] Bug#801772: python3-uwsgidecorators: Depends multiple versions of libpython3
debian at kitterman.com
Wed Oct 14 12:20:18 UTC 2015
Now that uwsgi-plugin-python3 is built with multiple versions of python3
(which is good), it Depends on multiple versions of libpython3 (which is bad).
Depends: libc6 (>= 2.14), libpython3.4 (>= 3.4.2), libpython3.5 (>= 3.5.0~b1),
uwsgi-core (= 184.108.40.206-1)
In reality it needs either one installed, not both.
There are a number of ways this could be expressed that would be more correct:
libpython3.4 (>= 3.4.2) | libpython3.5 (>= 3.5.0~b1)
or even better:
libpython3 (>= 3.4), libpython3 (<< 3.6)
More information about the pkg-uWSGI-devel