[pkg-uWSGI-devel] Bug#801772: Bug#801772: python3-uwsgidecorators: Depends multiple versions of libpython3
dr at jones.dk
Wed Oct 14 13:33:53 UTC 2015
Quoting Scott Kitterman (2015-10-14 14:20:18)
> Now that uwsgi-plugin-python3 is built with multiple versions of
> python3 (which is good), it Depends on multiple versions of libpython3
> (which is bad).
> Depends: libc6 (>= 2.14), libpython3.4 (>= 3.4.2), libpython3.5 (>=
> 3.5.0~b1), uwsgi-core (= 22.214.171.124-1)
> In reality it needs either one installed, not both.
> There are a number of ways this could be expressed that would be more
> libpython3.4 (>= 3.4.2) | libpython3.5 (>= 3.5.0~b1)
> or even better:
> libpython3 (>= 3.4), libpython3 (<< 3.6)
Hmm. Seems to be a general problem in CDBS not implementing Debian
Python Policy §3.5 correctly (or Policy has changed over the years):
* Jonas Smedegaard - idealist & Internet-arkitekt
* Tlf.: +45 40843136 Website: http://dr.jones.dk/
[x] quote me freely [ ] ask before reusing [ ] keep private
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 819 bytes
More information about the pkg-uWSGI-devel