Bug#473434: vdr-plugin-xineliboutput: bad versioned dependency "libxine1 (<< 1.1.12)"

Darren Salt linux at youmustbejoking.demon.co.uk
Sun Mar 30 16:15:56 UTC 2008

Source: vdr-plugin-xineliboutput
Version; 1.0.0~rc2-14

Changes in xine-lib mean that setting a maximum version number for the
libxine1 dependency is not required for xine-lib >= 1.1.11. (These changes
were made to avoid future problems with getting an updated xine-lib into
testing because of this package.)

A correctly-generated dependency would look like
  "libxine1 (>= $UPSTREAM_PART)"

You should be able to generate this by using the following command and making
the packages depend on ${xine:Depends}:

  dpkg -p libxine1 |
  sed -re '/^Version:/! d;
           s/^Version: (([0-9]+\.){2}[0-9]+).*$/xine:Depends=libxine1 (>= \1)/' \
  >> debian/substvars

(x.y.z is sufficient. If x.y.z.a is needed, it's a xine-lib bug.)

| Darren Salt    | linux or ds at              | nr. Ashington, | Toon
| RISC OS, Linux | youmustbejoking,demon,co,uk | Northumberland | Army
| + Output *more* particulate pollutants.      BUFFER AGAINST GLOBAL WARMING.

A bird in the hand is safer than one overhead.

More information about the pkg-vdr-dvb-devel mailing list