[sane-devel] [xsane-0.79] configure problem in SuSE 7.2

Oliver Schwartz Oliver.Schwartz@gmx.de
Wed, 1 Aug 2001 23:50:14 +0200


I just tried to compile xsane-0.79 on my SuSE 7.2 system and had some 
problems to enable gimp support.

After running "configure" I get the following
checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.2.0... yes
checking for gimp-config... no
checking for gimptool... /usr/bin/gimptool
checking for GIMP - version >= 1.0.0... no
*** Could not run GIMP test program, checking why...

In configure.log, I get:
configure:4499: checking for GIMP - version >= 1.0.0                          
configure:4589: gcc -o conftest  -Wall -I/usr/lib/glib/include 
-I/usr/X11R6/inclIn file included from configure:4511:
/usr/include/libgimp/gimp.h:25: glib.h: No such file or directory
In file included from /usr/include/libgimp/gimp.h:46,
                 from configure:4511:
/usr/include/libgimp/gimputils.h:40: parse error

However, glib.h is present in my system, it's just not included in the 
include search path.

I solved the problem by doing an 'export CPPFLAGS="-I/usr/include/gtk-1.2 
-I/usr/include/glib-1.2"' before running configure - but why won't it find 
glib.h in the first place?