[sane-devel] epson 1200 usb hangs

Bob Ramsey rramsey@soli.inav.net
Wed, 29 Aug 2001 08:18:44 -0500

I think I accidentally replied off list without thinking, so I'll try this 
again.  I'm using kernel 2.4.6.  The motherboard is a via, I forget the 
exact model, but it is pretty new; I just got this computer last June and 
it was a treat so I went pretty highend.  It is an Athlon 850 (remember, 
gigs weren't really available then) with 256 megs of ram.  The usb is on 
the motherboard.  Sunday and Monday I was able to scan at 750 dpi with no 
problem.  Last night I couldn't scan at 750 or 600.  When it displayed the 
same symptoms in the past, I also couldn't scan at 300.  I tried this 
morning at 75, and that worked.  600 didn't; it hung half way through the 
final scan.

I had a similar problem after I first compiled the front and backends, but 
it sort of cleared up eventually.  I never did figure out what I did that 
fixed it.  All I would do is reboot and rerun modprobe scanner.  Sometimes 
with the extra parameters from the epson sane faq sometimes not.  There was 
no consistency as to whether or not it worked.

One thing I forgot to mention (don't you hate to hear that) is that I have 
a wacom graphire tablet plugged into the first usb port.  That has been 
working fine ever since mandrake 7.2 and I've never had to configure 
it.  When the scanner hangs, the tablet goes out too.  I haven't tried 
removing the tablet and letting the scanner be the only usb device.

What really gets me is that I scanned in about 75 vacation pictures Sunday 
and Monday at either 600 or 750 dpi with no problems.  I can't scan more 
than 30 under windows without a reboot because, well, duh, windows.  There 
are 3 main reasons I would prefer to use xsane under Linux, and I'd like to 
thank the developers for their hard work.

1)  With default settings, what I see on the screen matches the color and 
exposure of the print I have in my hand.  This is not the case with the 
default settings using the epson drivers under windows.  I think this is 
just amazing and really impressive.

2)  The auto-increment/auto-save feature of the xsane software.  This is so 
nice and easy to use.  Oddly enough, scanning is one area (once it is 
working) that I think Linux has windows beat for ease of use.

3)  Linux can manage the memory better than windows.

Unfortunately I don't have any spare usb cards anywhere.  All the computers 
at home and at work have usb on the motherboard.  I don't mind picking up a 
card if you can reccommend one.

I've cleared out /tmp with rm -rf, so I don't think there are any loose 
files messing it up.  I've got 14 gigs free on the vfat partition where the 
pictures go and 500 megs free on the partition that contains /tmp.

Tonight when I get home from work I'll try unplugging the tablet.

Thanks for the help and suggestions,