[sane-devel] epson 1200 usb hangs

Karl Heinz Kremer khk@khk.net
Wed, 29 Aug 2001 15:30:37 -0000

Bob Ramsey <rramsey@soli.inav.net> said:

> I think I accidentally replied off list without thinking, so I'll try this 
> again.  I'm using kernel 2.4.6.  The motherboard is a via, I forget the 
> exact model, but it is pretty new; I just got this computer last June and 
> it was a treat so I went pretty highend.  It is an Athlon 850 (remember, 
> gigs weren't really available then) with 256 megs of ram.  The usb is on 
> the motherboard.  Sunday and Monday I was able to scan at 750 dpi with no 
> problem.  Last night I couldn't scan at 750 or 600.  When it displayed the 
> same symptoms in the past, I also couldn't scan at 300.  I tried this 
> morning at 75, and that worked.  600 didn't; it hung half way through the 
> final scan.

Your machine is new enough that it should not be the problem. I've seen
problems with the very first generation of USB interfaces on Intel based
boards. So testing with a new USB interface would not help.

[ ... ]
> One thing I forgot to mention (don't you hate to hear that) is that I have 
> a wacom graphire tablet plugged into the first usb port.  That has been 
> working fine ever since mandrake 7.2 and I've never had to configure 
> it.  When the scanner hangs, the tablet goes out too.  I haven't tried 
> removing the tablet and letting the scanner be the only usb device.

This means that your problem is not the timeout problem I was talking about
earlier. The timeout would only hang the scanner and not other devices on
the USB bus. 

Unplugging the tablet may be a good idea. Do you get any messages on the
console when the USB sub-system hangs? Can you "fix" it by just unplugging
the scanner and re-connecting it after e.g. five seconds (this should be
enough time to let the USB system settle down)?

Karl Heinz