[sane-devel] scsi module

DStevenson tech@dgssoftware.co.uk
Mon, 30 Jul 2001 21:59:52 -0400

On Monday 30 July 2001 07:16, tmarshall04 wrote:
> hi Dave,
>             ok here's what i have. last week you asked me which module my
> sane program was trying to use. when i run lsmod i get NO scsi modules but
> i can modprobe the sg.o module and the aic7xxx module also but when i run
> insmod for the aic7xxx module..it tells me "couldn't find the kernel
> version the module was compiled for"...this is strange because i haven't
> changed anything..it's a straight load of 6.2 (2.2.14 kernel) i've found
> info on the net saying to modify one of the .c files of the aic7xxx driver
> but when i do that and try a recompile of the kernel, it fails. i don't
> mean to be a pain but i'd really like to get this working ( i could use it
> on my wife's M$ box but i refuse to).
> thanks,
>    Mike
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

type:   	rmmod aic7xxx
	insmod aic7xxx_old


make sure the aic7xxx_old module in installed. Do a scanimage test in color 
and greyscale.

This worked for me, I hope it works for you. Let us know. I am no guru, just 
relaying my experience with sane.