[sane-devel] Brand-Newbie question

Jochen Eisinger jochen.eisinger@gmx.de
Sun, 14 Oct 2001 14:31:51 +0200

Hash: SHA1


Jim George wrote:

  > I've just installed sane with the mustek_pp backend.
  > I had no /dev/scanner entry in my /dev directory therefore, after much
  > scrabbling around and guessing, I created a symbolic link from
/dev/lp0 to
  > /dev/scanner.

the mustek_pp backend doesn't support devices yet, you have to specify
the port number of your parallel port in /etc/sane.d/mustek_pp.conf (or
/usr/local/etc/sane.d/mustek_pp.conf depending on your installation)

  > I chose /dev/lp0 as this is the entry in /etc/printcap  that equates to
  > the lp printer, and my mustek 1200cp scanner (CIS chipset with the
  > software patch from Eddy DeGreef) shares that port.
  > I edited /etc/sane.d/dll.conf and removed the comment in front of
  > mustek_pp.
  > I edited /etc/sane.d/mustek_pp.conf and changed the port to 0x3bc as per
  > the instrcutions in that file.
  > My problem is that when I run xsane I get the message 'no devices
  > available'.  I've tried specifying mustek_pp:/dev/scanner and
  > mustek_pp:/dev/lp0 (and 1).  But all of these fail.

In the file mustek_pp.conf you've also specified the name for the
scanner, which you want to use, for example "name SM-1200CP", then you
have to use the device mustek_pp:SM-12000CP. Furthermore, you can only
access the scanner as root. To allow users to scan, you have to setup
the SANE Network Scanner daemon. Descriptions of how to do this can be
found in the man-pages saned, sane-net & sane-mustek_pp or on the
web-page http://home.nexgo.de/jochen.eisinger/saned/


   -- jochen
  > Can someone tell me what I've done wrong, or have missed?
  > Thanks in advance,
  > Jim
  > _______________________________________________
  > Sane-devel mailing list
  > Sane-devel@www.mostang.com
  > http://www.mostang.com/mailman/listinfo/sane-devel

- --
    "I'd rather die before using Micro$oft Word"
      -- Donald E. Knuth
       (asked whether he'd reinvent TeX in the light of M$ Word)

    GnuGP public key for jochen.eisinger@gmx.de:

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org