[sane-devel] Problems with Epson 636U

James O'Test jameso@myeasyemail.com
Sun, 9 Sep 2001 19:20:55 +0100 (BST)

I just got myself a Epson636u Scanner and am having a bit of a problem with it.

I am new to scanning in general, so as I will try to give all the info that one might need to help me on this, feel free to hit me with the clue stick if I leave something out.

This is on a FreeBSD 4.4RC machine. Scanner is a Epson 636U, USB.

On FreeBSD, my scanner is connecting to the sytem as:

uscanner1: EPSON Perfection636, rev 1.00/1.04, addr 3

I have made sure to have my epson.conf file to read:

usb /dev/uscanner1

And I have tried to make sure that permissions on my permissions on the device correct:

crw-rw-rw-  1 root  operator  156,   1 Sep  9 00:57 uscanner1

Now, onto the problem...

Half the time, when I run xsane it hangs. Doing a trus on xsane, I can see that every time it hangs at this point:

open("./epson.conf",0,0666)                      ERR#2 'No such file or
open("/usr/local/etc/sane.d/epson.conf",0,0666)  = 6 (0x6)
fstat(6,0xbfbfec8c)                              = 0 (0x0)
read(0x6,0x80fd000,0x2000)                       = 399 (0x18f)
open("/dev/uscanner1",2050,027757766774)         = 7 (0x7)
write(7,0xbfbfd476,2)                            = 2 (0x2)

If I ctrl-c the process and re-run it enough, it will find the scanner. Once it does, and I try to do a preview, it will hang as well:

ioctl(3,FIONREAD,0xbfbfdfd8)                     = 0 (0x0)
poll(0x840f210,0x2,0x0)                          = 0 (0x0)
open("/dev/uscanner1",2050,027757763660)         = 6 (0x6)
write(6,0xbfbfe8a6,2)                            = 2 (0x2)

At this point, if I turn off and on the scanner, it will pop up with a error message, and then be able to do a preview. About 50% of the time when doing this preview, the process will core dump.

writev(0x3,0xbfbfc434,0x1)                       = 8192 (0x2000)
writev(0x3,0xbfbfc434,0x1)                       = 280 (0x118)
Process stopped because of:  16
process exit, rval = 139
Segmentation fault (core dumped)

The other half of the time, the preview will come through. Upon trying to do any other funtion that would involve talking to the scanner, the process will then core dump.

Has anyone seen anything like this before? I have a saved core file if that might help anyone.

Advice on where to go from here?