[sane-devel] Problems with Epson 636U

Karl Heinz Kremer khk@khk.net
Sun, 9 Sep 2001 20:34:14 -0400

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


unfortunately I am not familiar with Sane and any flavour of BSD systems.
A core dump does not help, there is an easier way of getting more informati=
You can create a log file that contains all the communication between the
scanner and the backend. This will hopefully help to identify what goes

Set the debug variable (depending on your shell you may have to use
a different syntax):
xsane > /tmp/scan.log 2>&1

You can use any other frontend with the same output redirection.

Karl Heinz

On Sun, Sep 09, 2001 at 07:20:55PM +0100, James O'Test wrote:
> I just got myself a Epson636u Scanner and am having a bit of a problem wi=
th it.
> I am new to scanning in general, so as I will try to give all the info th=
at one might need to help me on this, feel free to hit me with the clue sti=
ck if I leave something out.
> This is on a FreeBSD 4.4RC machine. Scanner is a Epson 636U, USB.
> On FreeBSD, my scanner is connecting to the sytem as:
> uscanner1: EPSON Perfection636, rev 1.00/1.04, addr 3
> I have made sure to have my epson.conf file to read:
> usb /dev/uscanner1
> And I have tried to make sure that permissions on my permissions on the d=
evice correct:
> crw-rw-rw-  1 root  operator  156,   1 Sep  9 00:57 uscanner1
> Now, onto the problem...
> Half the time, when I run xsane it hangs. Doing a trus on xsane, I can se=
e that every time it hangs at this point:
> open("./epson.conf",0,0666)                      ERR#2 'No such file or
> directory'
> open("/usr/local/etc/sane.d/epson.conf",0,0666)  =3D 6 (0x6)
> fstat(6,0xbfbfec8c)                              =3D 0 (0x0)
> read(0x6,0x80fd000,0x2000)                       =3D 399 (0x18f)
> open("/dev/uscanner1",2050,027757766774)         =3D 7 (0x7)
> write(7,0xbfbfd476,2)                            =3D 2 (0x2)
> If I ctrl-c the process and re-run it enough, it will find the scanner. O=
nce it does, and I try to do a preview, it will hang as well:
> ioctl(3,FIONREAD,0xbfbfdfd8)                     =3D 0 (0x0)
> poll(0x840f210,0x2,0x0)                          =3D 0 (0x0)
> open("/dev/uscanner1",2050,027757763660)         =3D 6 (0x6)
> write(6,0xbfbfe8a6,2)                            =3D 2 (0x2)
> At this point, if I turn off and on the scanner, it will pop up with a er=
ror message, and then be able to do a preview. About 50% of the time when d=
oing this preview, the process will core dump.
> writev(0x3,0xbfbfc434,0x1)                       =3D 8192 (0x2000)
> writev(0x3,0xbfbfc434,0x1)                       =3D 280 (0x118)
> Process stopped because of:  16
> process exit, rval =3D 139
> Segmentation fault (core dumped)
> The other half of the time, the preview will come through. Upon trying to=
 do any other funtion that would involve talking to the scanner, the proces=
s will then core dump.
> Has anyone seen anything like this before? I have a saved core file if th=
at might help anyone.
> Advice on where to go from here?
> Thanks!
> Jim
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

Karl Heinz Kremer                                  khk@khk.net
PGP Key at http://www.freecolormanagement.com/download/khk.asc
EPSON Sane Backend:         http://www.freecolormanagement.com

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: PGP 6.5.8