[sane-devel] Got 1.0.9 installed. Only runs as root...

David Hostetler dbhost@longhornpenguin.com
Sat, 28 Dec 2002 08:07:09 +0000

Hash: SHA1

(cc'ed to the sane mailing list)

Henning Meier-Geinitz helped me in my prior inquiry at the end of november 
when I asked about 1.0.8 and dropped backends. He suggested I run...

> make distclean ; ./configure ; make

Which helped. Let me back the story up to bring everyone else up to speed so 
you know what I had to do to get where I am now.

I upgraded from Mandrake 8.2 to 9.0, and installed the sane rpms that shipped 
with 9.0. My Microtek Scanmaker 3700 that had been working for quite some 
time now under sane (thank you developers!) quit working. After all my 
searching through the files, and an rpm query or two I discovered that the 
1.0.8 sane that ships with Mandrake is screwy and missing many backends from 
the sane backends package. 
I uninstalled 1.0.8 and grabbed the older version from my 8.2 CDs. This did 
not appear to change anything. 
So I uninstalled that and grabbed the source for 1.0.8 and built it with no 
success. did a make uninstall and grabbed 1.0.9 with no success, that 
Microtek Backend simply wouldn't show up. I got the command info from 
Henning, thought the old rpm installs might be messing with things, and so I 
ran rpm --rebuilddb to clean up any links to files from now uninstalled 
I then ran make distclean from the 1.0.8 directories, and then removed the 
1.0.8 directories. Then I ran the full make distclean && ./configure && make 
&& make install from the 1.0.9 directory. I then ran sane-find-scanner and 
found the scanner, which doesn't identify by name but does show up now. I 
then ran xsane as root, and the scanner works, but I cannot use it as a 
regualr user. I cannot seem to find the scanner0 device anywhere, so I am not 
sure where to look to allow joe blow users access to the device. So my 
question after this long winded explaination is this. What and where do I 
have to change permissions to allow access to regular users to the scanner?

BTW my offer from the past stands. Code is out, but I will donate graphics 
work to this project. Just point me in the right direction and I am ready to 

- -- 
David B. Hostetler
Version: GnuPG v1.0.7 (GNU/Linux)