[sane-devel] Microtek ScanMaker 3700 SANE 1.0.9 and Mandrake 9.0

David Hostetler dbhost@longhornpenguin.com
Tue, 31 Dec 2002 13:29:55 +0000

Hash: SHA1

For starters please forgive me for asking dumb questions. I am trying to 
learn, and this is a huge learning curve for me to tackle.

I have a Microtek ScanMaker 3700 (sane backend sm3600) that worked 
fantastically on Mandrake 8.1, 8.1, and 8.2 using sane 1.0.6 and 1.0.7. I 
upgraded (questionable if that was an upgrade) to Mandrake 9.0 and the 
scanner stopped being recognized. I checked into the rpm file and found the 
sm3600 backend was missing. I then attempted to install the rpm from 8.2 with 
sane 1.0.7 with no luck. I then uninstalled all that junk and tried to 
install sane 1.0.9 from source and had screaming fits. 
Following Henning Meier Gennitz' suggestion (sorry if I misspelled) I ran make 
distclean after uninstalling the 1.0.9. On my own initiative I ran rpm 
- --rebuilddb to clean up all the old rpm stuff. And then I rebuilt 1.0.9 with 
some success. I can access the scanner as root. I then read the man 
sane-sm3600 manpage, and the hotplugging howto on the sm3600 backend site. My 
logs show what the authors seem to think I should see, but I still have no 
user level access to the scanner.

scanimage -L flat out won't see the scanner and xsane dies just as it begins 
to try to detect the scanner.

This has got to be a permissions issue somewhere I have overlooked. Can 
somebody tell me what files need to be given user level access to so I can 
get this thing running?


Much more of this and I am buying an Epson!

- -- 
David B. Hostetler
Version: GnuPG v1.0.7 (GNU/Linux)