[sane-devel] sane doesn't find my Epson Perfection 1650

Jason M. Burns burns@math.mit.edu
Sun, 21 Jul 2002 14:23:25 -0400

I can find my scanner (an Epson 1650) in /proc/bus/usb/devices
and in sane-find-scanner's output, but when I run scanimage it tells me
'scanimage: no SANE devices found'.  xsane gives a similar error.

I'm running Red Hat 7.2.

Things I've tried:
1) 'modprobe scanner'; I need to do this to have the system see the scanner.
2) Specifying the options 'vendor=0x04b8 product=0x0110' when modprobe'ing,
   or in modules.conf.
3) Upgrading sane to 1.0.7, from the RedHat 7.3 packages
(sane-frontends, sane-backends, sane-backends-devel, and xsane-0.84).
4) Upgrading my kernel from 2.4.7-10 to 2.4.9-34.
5) Adding the line 'usb /dev/usb/scanner0' to epson.conf, and
   commenting out all other lines; this is the device reported by
6) Changing permissions on /dev/usb/scanner0 from 600 (read/write for
   user jason only) to 666; this shouldn't make any difference, because
   I've tried all these as user jason, but I'm out of ideas.
7) Replacing dll.conf with the single line 'epson', to avoid using
   other backend drivers.

Jason Burns