[sane-devel] sane doesn't find my Epson Perfection 1650

Henning Meier-Geinitz henning@meier-geinitz.de
Sun, 21 Jul 2002 20:53:21 +0200


On Sun, Jul 21, 2002 at 02:23:25PM -0400, Jason M. Burns wrote:
> I can find my scanner (an Epson 1650) in /proc/bus/usb/devices
> and in sane-find-scanner's output, but when I run scanimage it tells me
> 'scanimage: no SANE devices found'.  xsane gives a similar error.
> I'm running Red Hat 7.2.
> Things I've tried:
> 4) Upgrading my kernel from 2.4.7-10 to 2.4.9-34.

Still pretty old, but that shouldn't matter.

> 5) Adding the line 'usb /dev/usb/scanner0' to epson.conf, and
>    commenting out all other lines; this is the device reported by
>    sane-find-scanner.

/dev/usb/scanner0 is the device sane-find-scanner found?

> 6) Changing permissions on /dev/usb/scanner0 from 600 (read/write for
>    user jason only) to 666; this shouldn't make any difference, because
>    I've tried all these as user jason, but I'm out of ideas.
> 7) Replacing dll.conf with the single line 'epson', to avoid using
>    other backend drivers.

Looks ok. Now try to find out, what's wrong:

scanimage --version (to make sure that the update was ok)

SANE_DEBUG_EPSON=255 scanimage -L

should print some debug messages. If you don't get these debug
messages, something is wrong with your SANE installation. Try

SANE_DEBUG_DLL=255 scanimage -L

in this case and try to reinstall the SANE pacakges.

If you got the epson dbg messages, show them to us :-)