[sane-devel] Umax Astra 1200S seen but not responding (long)

Hubert Figuiere hfiguiere@teaser.fr
Fri, 17 May 2002 18:51:45 +0200

According to Michael J Flaherty <mikeflaherty@mn.rr.com>:

> As the subject says, I'm having trouble with my SCSI UMAX 1200S.  It appears 
> to me to be a SCSI related problem.  I don't know whether it is a result of 
> the kernel or sane.   
> I'm using sane 1.0x (not sure which, but the YDL distro is only a month old 
> so it's pretty current) and Xsane 0.84.
> (stock 2.4.18 kernel, Yellow Dog Linux 2.2 on a Power Mac 7300 w/G4 card and 
> ATA  100 card, machine has 2 motherboard SCSI buses, boots from an ATA 100 
> drive attached to the card, the scanner is the only device on its bus, 
> connected to the external mobo 25 pin SCSI port with a 1 meter SCSI cable. )
> The scanner works perfectly in Mac OS 9.1, without a terminator attached, but 
> not when it is attached.  Doesn't work in Linux whether the terminator is 
> attached to the scanner or not.  

Amen. I have an Astra 1220S, a PowerCenter Pro 240 (basically a 7300
with a bumped up CPU and a real video card) and it fails miserably
aswell when the scanner is plugged on the internal SCSI controller
(the NCR one).
So I'm not alone. :-)

> I have several questions that I would very much appereciate an answer to:
> Is it normal for sane-find-scanner to find my scanner "twice" (see below) ?

Sort of. You have 2 /dev/sg device that points to the same real SCSI
device. It does it for me because /dev/scanner is a link to the sg
device it is on.

> Once sane freezes, can I reset the SCSI bus without rebooting ?

I could not find a way. That only prevents the scanner from being
detected again.

> What specific options should I try in umax.conf (or is it a SCSI problem 
> whose solution lies elsewhere) ?  

If there is a solution, I'd like to know.

Think I haven't tried: 

-moving to 2.4 kernel (still use a 2.2.20), but apparently you have
-using the AHA 2930B card for the UMAX. Last time I tried, I could no
longer boot (my boot disk is on this controller).

Side note: my CoolScanIII LS30 works like a charm in this AHA 2930B. I
haven't tried on the other controller due to lack of proper SCSI cable.