[sane-devel] Epson 1650 out of memory

Henning Meier-Geinitz henning@meier-geinitz.de
Mon, 30 Sep 2002 23:36:03 +0200


On Mon, Sep 30, 2002 at 10:32:27PM +0200, Henk Abma wrote:
> I run a machine with 512mb of ram and gentoo linux, with its default
> compilation of sane. When I try to scan like this:
> scanimage --resolution 1600 --mode color -x 180 -y 100 |cjpeg --quality=85 >picture.jpg 
> I get an 'out of memory' error, with no indication who goes out of
> memory. I run the computer without X, so I should have more than
> enough ram available.

The image size is 204 MB if I didn't make a mistake. However, it
doesn't look like as if any of the programs buffers the whole image.
When I try that with the test backend, I don't have any problems and
the meomory usage is low. Maybe you can try the test backend also 
(-d test) to find out if it's a problem with the epson backend.

I tried:

scanimage -d test --resolution 1600 --mode color -x 400 -y 400 |cjpeg
-quality 85 >picture.jpg

--quality=85 doesn't seem to be recognised by my version so maybe we
have different versions:

Independent JPEG Group's CJPEG, version 6b  27-Mar-1998
Copyright (C) 1998, Thomas G. Lane

Ok, pretty old :-)