[sane-devel] Problems problems problems

Henning Meier-Geinitz henning@meier-geinitz.de
Wed, 2 Apr 2003 11:14:24 +0200


On Wed, Apr 02, 2003 at 11:36:21AM +0200, Steven Lobbezoo wrote:
> It's amazing that no one ever writes about something that was a succes to a 
> mailing list, but i'm affraid i have to confirm to this standard ;-))

Ok, so just for the record: 26 of my 29 scanners work fine with SANE :-)

> I'm working with Linux Suse 8.1 and sane 1.0.8-47  on a PC.
> My scanner is a Epson Perfection 1260 (USB).
> I installed one in a seperate office, no problem. Took me 5 minutes and with 
> Gimp and XSane it was working like a charm!
> Then i started installing in this office (same software, same scanner), and I 
> cannot get it to work.

Same kernel version?

> I tried to install the latest release of sane, but it needs GLIBC2_3,

The source code does not depend on any specific glibc version. In
fact, it doesn't depend on glibc at all.

> and i cannot install that (inpossible to find a compiled version, try
> to compile myself, but the library does not work - after 2 days i
> gave up on that).

The source code from mostang.com works. Believe me :-)
Ig you give more details, we may find the problem. But as you say the
scanner orks eith the "Old" sane-backends package, it should also do
on the other computer.

> So i went back to the mentioned version. The scanner is recognized by
> the system. As soon as i put the cable in it appears on my desktop,
> it seems to be ok, when i make a hardware scan it's found, KDE say's
> it's just fine.

Ignore all this high-level stuff unless you really know what it means.
Does "KDE say's it's just fine" mean that he kernel scanner driver has
detected the scanner and the permissions are set up correctly? I'm
pretty sure KDE just doesn't know. So ignore it.

> But if i try to start Xsane (or do the test during Yast installation) it just 
> hangs! Nothing happens. I tried to start "xsane /dev/usb/scanner0", but then 
> it comes back with an error 5 and dumps core.

Start with the basic tests and then go to the more complicated ones:
Is the scanner found by sane-find-scanner? If it's not found, even not
as root, it wasn't detected by the kernel scanner driver. You may need
to use modprobe options to get it detected: something like "modprobe
scanner vendor=0x1234 product=0x2345". Get the correct ids from syslog
or one of the USB tools you mentioned.

If it's detected, run scanimage -L. Not found? Check that "plustek" is
in dll.conf and /dev/usb(scanner0 is mentioned in plustek.conf
(instead of the default /dev/usbscanner). If it still doesn't work, run
SANE_DEBUG_PLUSTEK=255 scanimage -L

And show us the output.

I'll rewrite the PROBLEMS section of the sane manpage now so I can
xopy this explanation the next time :-)