[sane-devel] Could not locate Fujitsu fi-410c (untested?)

Henning Meier-Geinitz henning at meier-geinitz.de
Sun Apr 6 12:07:17 BST 2003


I had to reformat your message because it's HTML again. That's the
last time I respond to a HTML-only email.

On Sun, Apr 06, 2003 at 02:28:02AM +0000, peter chen wrote:
>   In order to use Fujitsu fi-4120c, I did the following:

>   2. add 'options scanner vendor=0x04c5 product=0x1041' to
>   /etc/modules.conf (to my surprise, when I powered fi-4120c on, and cat
>   'proc/bus/usb/devices', the product id was 0x1041 instead of 0x0142
>   for fi-4120c)

Maybe I got the ids mixed when adding them to the kernel scanner
driver. What I have is:

| /* Fujitsu */
|   { USB_DEVICE(0x04c5, 0x1041) }, /* fi-4220c USB/SCSI info:mza at mu-tec.de  
|   { USB_DEVICE(0x04c5,0x1042) }, /* fi-4120c USB/SCSI info:mza at mu-tec.de
|   { USB_DEVICE(0x04c5, 0x1029) }, /* fi-4010c USB AVision info:mza at mu-tec.

The "41" and "42" may be a coincidence but it may also be an
indication for a mixup.

All the following is just guessed, I'm not the fujitsu maintainer:

>   then I ran sane-find-scanner, it reported it found usb scanner at
>   /dev/usb/scanner0, then I ran scanimage -L, scanimage --list-devices,
>   but they could not locate the scanner.

fujitu.conf is set up correctly? I guess you need to add something like
"usb /dev/usb/scanner0".

>   I read from an article saying that the Linux kernel should be at least
>   2.4.8 to work with the latest SANE (my Redhat 7.1 is 2.4.2-2), is this
>   the reason?

I don't think so in this case. You need the newer versions if you want
to do autodetection using the vendor and product ids. For manually
setting the device file name it should work.

>   And the product id is different (0x1041 instead of 0x1042) for
>   fi-4120c, could this be the reason?

I don't think so, either. Looks like the backend soen't check the ids
at all.

>   I am considering re-installing Redhat Linux 9 and try again.

Ususally it doesn't help to reinstall anything. Setting up software
may help :-)

>   Is an error log necessary?

If setting up fujitsu.conf doesn't help, show us the output of
SANE_DEBUG_FUJITSU=255 scanimage -L


More information about the sane-devel mailing list