[sane-devel] USB Scanner Problem

Peter Kirchgessner peter@kirchgessner.net
Tue, 26 Aug 2003 07:08:10 +0200

Hi Jan,

is this scanner really a HP ScanJet 4200c. USB says that it is a ScanJet 
6200c. But that doesn't matter.
After the first (and only) scan has completed, do the following:

export SANE_DEBUG_HP=255

scanimage > hp.ppm 2>hp.lis

and send hp.lis back to me.



Jan Rüdiger schrieb:
> Hi
> I try to connect a HP 4200C to my PC running SuSe 8.2 with Kernel 2.4.20 
> and sane 1.0.11 (also tried 1.0.12). The Problem is that the scanner 
> only works for one scan after that sane doesn't find any devices. The 
> only solution is to reload the usb-uhci modul (rmmod/insmod usb-uhci) 
> I'm not sure if this is a kernel or sane problem, can someone please 
> point me in the ritght direction.
> I'll access the scanner via libusb. I'll tested the scanner on 3 
> different PC and the scanner works under w2k.
> scanimage -L reports:
> No scanners were identified. ...
> but
> sane-find-scanner reports:
> found USB scanner (vendor=0x03f0, product=0x0201) at libusb:001:002
> cat /proc/bus/usb/devices gives:
> P:  Vendor=03f0 ProdID=0201 Rev= 1.00
> S:  Manufacturer=Hewlett-Packard
> S:  Product=HP ScanJet 6200C
> S:  SerialNumber=0G95911204HL
> I also tried all tips from the hp-faq without any luck.
> thanks allot
> jan
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

Peter Kirchgessner