[sane-devel] Problems running saned from xinetd

Emmanuel Gravel e_gravel@yahoo.com
Wed, 10 Dec 2003 17:56:08 -0800 (PST)

--- Henning Meier-Geinitz <henning@meier-geinitz.de> wrote:
> Hi,
> On Wed, Dec 10, 2003 at 12:33:07PM -0800, Emmanuel Gravel wrote:
> > Tried that too, since I found it on the net. Didn't work. I'll send the
> full
> > contents and all future testing info when I get to my system again.
> Check that the group you use in xinetd.conf does exist. And that the
> path to the daemon is correct. It looks like a problem with xinetd
> starting saned. You don't use "-d" or "-s" as options for saned? That
> only works in stand-alone mode.
> If you can't find out what's wrongf, you could move saned to
> saned.bin, write a wrapper shell script that prints something to
> /tmp/log.txt and starts saned.

No luck getting anything out of this right now.

Contents of my saned file in /etc/xinetd.d:
service sane
   port        = 6566
   socket_type = stream
   protocol    = tcp
   wait        = no
   user        = saned
   group       = saned
   disable     = no
   server      = /usr/sbin/saned

>From a standard user (i.e. not root, not saned) starting saned with -d works.
With this, xinetd is listening on 6566. It also listens on 6566 as standalone
when running as a user.

I did both the direct saned, and the shellscript-wrapped saned.bin. Neither
works, no output to text file. I tried running as a user with the shell wrap
(added -d to the script) and it works, and creates the output files.

Here's a which saned call:
xinetd.d # which saned

So I really don't know where to look now. It's definetely an issue with xinetd
not passing control properly to saned, it seems, but I still don't know what to
look at. I'm not running any other server with it, so I don't know if it works
in general, but I know that there's a listener there.

Any ideas?


Do you Yahoo!?
Free Pop-Up Blocker - Get it now