[sane-devel] Problems running saned from xinetd

Emmanuel Gravel e_gravel@yahoo.com
Wed, 10 Dec 2003 14:32:10 -0800 (PST)

--- Henning Meier-Geinitz <henning@meier-geinitz.de> wrote:
> Hi,
> On Wed, Dec 10, 2003 at 12:33:07PM -0800, Emmanuel Gravel wrote:
> > Tried that too, since I found it on the net. Didn't work. I'll send the
> full
> > contents and all future testing info when I get to my system again.
> Check that the group you use in xinetd.conf does exist. And that the
> path to the daemon is correct. It looks like a problem with xinetd
> starting saned. You don't use "-d" or "-s" as options for saned? That
> only works in stand-alone mode.
> If you can't find out what's wrongf, you could move saned to
> saned.bin, write a wrapper shell script that prints something to
> /tmp/log.txt and starts saned.
> Bye,
>   Henning

Tried doing the wrapper script as found elsewhere (no files were ever created
though), checked the path (mine was in /usr/sbin/saned) and created the
user/group myself. Not using the -d or -s option with xinetd either... 

I'll do a few more tests when I get home, and triple-check everything.

BTW the goup shouldn't matter much for /dev/usb/scanner0 since it has rw perms
for all.

Do you Yahoo!?
Free Pop-Up Blocker - Get it now