[sane-devel] Epson 1640SU, no devices found, RH 8.0

Henning Meier-Geinitz henning@meier-geinitz.de
Mon, 15 Dec 2003 19:14:31 +0100


please reply to sane-devel, not me personally. This issue is of
interest for others, too.

On Mon, Dec 15, 2003 at 02:20:47PM +0100, Torben Andersen wrote:
> Thanks to everybody; especially Henning and the author of sane-epson: 
> Karl Heinz. I maded it work by uninstalling everything and reinstalling 
> from RPM AND it worked ! But before I tried from source with 
> "./configure --prefix=/usr", make, make install and got this interesting 
> installation:
> [root@0x50a12f26 sane-backends-1.0.13]# ll /usr/lib/sane/libsane.so.1
> lrwxrwxrwx    1 root     root           21 dec 15 14:02 
> /usr/lib/sane/libsane.so.1 -> libsane-v4l.so.1.0.13
> So unless something is really rotten in my computer, there is a problem 
> with the sourcepackage (Henning mentioned this - look above). Or has I 
> misunderstood something ??

You are right. It's not exactly SANE but libtool who creates a link
"libsane.so" to "libsane-something.so.version". I don't think that's a
good idea, but that's libtool :-)

It happens to be a link to the v4l backend because that's just
alphabetically the last one. The other links are just overwritten by
that one.

We could remove the link in the Makefile but that's not really clean

I have no idea why I didn't see that file when I looked for it last

Anyway, the actual problem is probably that "/usr/lib/sane/" is in
/etc/ld.so.conf. It shouldn't.