[sane-devel] Epson 1640SU, no devices found, RH 8.0

Torben Andersen the.beauty@adslhome.dk
Mon, 15 Dec 2003 20:00:19 +0100

Thanks to everybody; especially Henning and the author of sane-epson:
Karl Heinz. I maded it work by uninstalling everything and reinstalling
from RPM AND it worked ! But before I tried from source with
"./configure --prefix=/usr", make, make install and got this interesting

[root@0x50a12f26 sane-backends-1.0.13]# ll /usr/lib/sane/libsane.so.1
lrwxrwxrwx    1 root     root           21 dec 15 14:02
/usr/lib/sane/libsane.so.1 -> libsane-v4l.so.1.0.13

So unless something is really rotten in my computer, there is a problem
with the sourcepackage (Henning mentioned this - look above). Or has I
misunderstood something ??

But again thanks for the help !

Regards Torben

Henning Meier-Geinitz wrote:

>Yes. I've gotten one similar report. I guess it's a bug in the RPM.
>Here is an explanation on what happens:
>Usually the frontends are linked to libsane.so. It's located in
>/usr/lib/. This is the so-called "dll" backend which loads all the
>other SANE backends like libsane-epson.so. Those backends are located
>in /usr/lib/sane/. For some unknown reason in your RPM there is a
>/usr/lib/sane/libsane.so and that one is the one used by scanimage.
>For yet another unknown reason that file is libsane-v4l.so in reality.
>That's the backend for video for linux (video cards). So when you rund
>scanimage, only the v4l backend is loaded. You can only use video
>cards, no scanners or other devices.
>Short summary: your RPM is broken. 
>SANE itself (as on our website) does NOT link to
>/usr/lib/sane/libsane.so and does NOT even contain
>So the soultion is to use a working RPM. Don't ask me who broke the
>RPM, it's not us at least :-)
>  Henning