[sane-devel] Epson 1640SU, no devices found, RH 8.0

Oliver Rauch oliver.rauch@rauch-domain.de
Mon, 15 Dec 2003 20:28:56 +0100

Hello Henning, Torben, Tim

I juste took a look at redaht 9.0

The problem is that in redhat 9.0 there is listed /usr/lib/sane in=20
the second problem is that there is a link /usr/lib/sane/libsane.so.1 to
a libsane library in the same directory. (this makes ldconfig changing th=
link). There also is a copy of a libsane.so.1 library in /usr/lib but thi=
seems not to be used ( I think /usr/lib/sane is searched before /usr/lib =
so this library does not correct anything.

It is a buggy configuration in redhat 9.0 and this also causes
problems when the rpm is uninstalled and sane-backends is
installed from source with -prefix=3D/usr because the entry /usr/lib/sane
is not removed from /etc/ld.so.conf when the sane-backends rpm
is uninstalled.

When there will ever be a redhat distribution then anyone at redhat (Tim?=
should make sure that this is corrected in the future:
- remove /usr/lib/sane from /etc/ld.so.conf
- move link libsane.so.1 from /usr/lib/sane to /usr/lib

Best regards

On Monday 15 December 2003 20:00, Torben Andersen wrote:
> Thanks to everybody; especially Henning and the author of sane-epson:
> Karl Heinz. I maded it work by uninstalling everything and reinstalling
> from RPM AND it worked ! But before I tried from source with
> "./configure --prefix=3D/usr", make, make install and got this interest=
> installation:
> [root@0x50a12f26 sane-backends-1.0.13]# ll /usr/lib/sane/libsane.so.1
> lrwxrwxrwx    1 root     root           21 dec 15 14:02
> /usr/lib/sane/libsane.so.1 -> libsane-v4l.so.1.0.13
> So unless something is really rotten in my computer, there is a problem
> with the sourcepackage (Henning mentioned this - look above). Or has I
> misunderstood something ??
> But again thanks for the help !
> Regards Torben
> Henning Meier-Geinitz wrote:
> >Yes. I've gotten one similar report. I guess it's a bug in the RPM.
> >
> >Here is an explanation on what happens:
> >
> >Usually the frontends are linked to libsane.so. It's located in
> >/usr/lib/. This is the so-called "dll" backend which loads all the
> >other SANE backends like libsane-epson.so. Those backends are located
> >in /usr/lib/sane/. For some unknown reason in your RPM there is a
> >/usr/lib/sane/libsane.so and that one is the one used by scanimage.
> >For yet another unknown reason that file is libsane-v4l.so in reality.
> >That's the backend for video for linux (video cards). So when you rund
> >scanimage, only the v4l backend is loaded. You can only use video
> >cards, no scanners or other devices.
> >
> >Short summary: your RPM is broken.
> >
> >SANE itself (as on our website) does NOT link to
> >/usr/lib/sane/libsane.so and does NOT even contain
> >/usr/lib/sane/libsane.so.
> >
> >So the soultion is to use a working RPM. Don't ask me who broke the
> >RPM, it's not us at least :-)
> >
> >Bye,
> >  Henning