[sane-devel] Latest iscan-1.52-1 rpm for RH8.0

Gene Heskett gene.heskett@verizon.net
Sun, 21 Dec 2003 20:30:10 -0500

On Sunday 21 December 2003 13:26, Terry Boldt wrote:
>On Saturday 20 December 2003 23:02, you wrote:
>> On Saturday 20 December 2003 16:04, Terry Boldt wrote:
>> >I have compiled and installed the Epkowa iscan using gcc 3.2 with
>> > no problem, if you desire I can send you the compiled iscan.
>> >
>> >iscan works with sane - it is a sane frontend the same as xsane
>> > is a sane frontend - so iscan works with sane, but not xsane
>> > since they are essentially the same thing.
>> >
>> >Let me know if you desire the compiled iscan front end and/or the
>> > compiled epkowa sane backend.
>> Humm, something must have changed in the way of dependencies here.
>> it built without incident, and installed, but in August, the last
>> time I tried to do 1.5.2 from tarball, right after it was
>> released, the compiler spit it out.  This time it completed.
>> However that means I should have a GT-6800 backend, but if I
>> uncomment epkowa in /usr/local/etc/sane.d/sane.dll, it isn't
>> showing up in the
>I have the perfection 1660 Photo, but the epkowa backend should work
> for the GT-6800 if the epkowa web page lists it. You will have to
> add the line
>to the file
>iscan and xsane should then find the scanner. Anything past that and
> you are getting out of my depth. Sorry. Hope this helps.

Well, after I found it would build yesterday, I did the full install, 
and added the epkowa to the /usr/local/etc/sane.d/dll.conf, then made 
sure that epkowa did have any parport stuff uncommented.  For iscan I 
still get the same message, and clicking on my xsane icon has now 
reduced my choices by several, and epson or epkowa isn't one of them.  
I've lost the test backends that I did have showing up there, and now 
I have only a pair of bttv related sources and the plustek backend.

The plustek backend except for one very small artifact looks and works 
great.  Unforch I can't say the same for the bttv related stuff, its 
only good for one preview capture and all subsequent attempts get an 
out of sync preview.  The pix in tvtime remains its usual off-air and 
noisey self, I need to get a genuine cable feed to the win-tv go + 

I suppose the next thing would be to strace the iscan execution.  
Humm, at the point where the requestor pops up, it has spent some 
time looking for 'gtkrc.en'.  KDE system, only gnomish stuff is 
whatevers left over from the RH8.0 install.

Even earlier, it can't find libsane-net.so.1 either.

In /usr/local/lib/ I have
[root@coyote root]# ls /usr/local/lib/libsane*
/usr/local/lib/libsane.la  /usr/local/lib/libsane.so.1       
/usr/local/lib/libsane.so  /usr/local/lib/libsane.so.1.0.10  

Oh well, xsane works, too bad iscan won't.

>> xsane choice window yet, all I'm seeing is the plustek backend
>> (its an epson 1250u).  Is there something else I need to do? 
>> Running iscan from the cli gets me a "failed to send message to
>> scanner" advisory window, but no more.
>> Thanks for any other suggestions you can make Terry.

Cheers, Gene
AMD K6-III@500mhz 320M
Athlon1600XP@1400mhz  512M
99.22% setiathome rank, not too shabby for a WV hillbilly
Yahoo.com attornies please note, additions to this message
by Gene Heskett are:
Copyright 2003 by Maurice Eugene Heskett, all rights reserved.