[sane-devel] How to download files for Artec e+48u scanner?

Bjoern Brill brill@fs.math.uni-frankfurt.de
Mon, 22 Dec 2003 13:12:00 +0100 (CET)

On Fri, 19 Dec 2003, cr wrote:

> > >
> > > Is there anywhere I can download just the e+48u libsane and conf files
> > > from? Where (in a Debian system) should those files go?
> >
> > I doubt that dropping newer .so files into an old installation  would
> > work. Look at http://www.apt-get.org/ for a newer libsane package
> > compiled for woody. Adrian Bunk's excellent backports collection should
> > have one. libsane is about 2 megabyte, so it's not that huge. Maybe you
> > need a newer libusb package as well, but try with the one you have first.
> Many thanks for the detailed advice.   Apologies for the long delay in
> acknoleding it, I was fiddling around tryong to get things to work.  However,
> I seem to be going backwards.     :(
> I downloaded libsane_1.0.12-4.bunk_i386.deb from www.apt-get.org (or from the
> link it pointed to).
> Tried to install it using Kpackage (which invoked  dpkg -i ...)    I got an
> error message of unmet dependencies -  gphoto2 and libieee1284-3.
> I could try downloading those but I'm afraid of ending up in a cascade of
> dependencies.   I'd assumed Adrian Bunk's packages should be compatible with
> what's already in Woody.
Sometimes, backporting a package involves backporting some of its
dependencies as well. Those will then usually be provided in the same
repository. I wasn't aware this was the case with libsane, too. Now,
having had a look at it:
  - gphoto2 _is_ in woody, and libsane_1.0.12-4.bunk_i386.deb depends
    on version >= 2.0final-4, which is exactly the one in woody. It seems
    Kpackage doesn't do automatic dependency resolution?
  - libieee1248 is _not_ in woody. It _is_ in Adrian Bunk's backports
    collection, weights about 24KB and has no further non-woody

> I see that my /etc/sane.d/ directory now contains  *.conf.dpkg-new
> equivalents of all the original  *.conf files, plus one for the
> artec_eplus48u.
> However, sane-find-scanner (which worked OK when I previously tried it) seems
> to have completely disappeared.   I get 'command not found'.   I can't find
> it anywhere in my system.
> This is frustrating.

It turns out that the utilities shipped with libsane have been split out
into a separate package, sane-utils. However, this is advertised in the
description of the new libsane package, which one can read with e.g.
"dpkg  --info libsane_1.0.12-4.bunk_i386.deb"
(and presumably also with Kpackage, but I don't know or use this tool).
A matching sane-utils package is also available from the Bunk repository,
82KB, no further external dependencies.

> (Later...)
> I just did  apt-get -f install which removed sane, xsane and libsane.
> Then I did apt-get install sane and apt-get install xsane (off the Woody
> CD's) which put sane 1.0.7 back and now   sane-find-scanner works.    Which
> is where I was at before...
> I think I may just upgrade to Sarge (which should be due for release any day
> now) and hope that includes the Artec 48u backend.
As it looks at the moment, the next Debian release is still several months
away. Upgrading to the testing distribution now would probably give you at
least as rough a ride, but YMMV.

Best regards,

Bj"orn Brill <brill@fs.math.uni-frankfurt.de>
Frankfurt am Main, Germany