[sane-devel] libusb doesn't seem to work

Gene Heskett gene.heskett@verizon.net
Thu, 25 Dec 2003 23:04:35 -0500

Holiday Greeetings to all;

I just rebooted to a 2.6.0-mm1 kernel, rebuilt without

Its my understanding from copying the mail here that this should
force the use of libusb since the scanner in the kernel usb stuff
is being deprecated.

And, I've tried to install the tar.gz if libusb-0.1.7 but do not
know if its complete since the make bailed out for lack of
docbook stuff on this machine.  But a make install immediately
after didn't bail.  And I ran ldconfig after the install.

It seems to be there:
[root@coyote root]# ls -l /usr/local/lib/libusb*
lrwxr-xr-x    1 root     root           19 Dec 25 21:10 /usr/local/lib/libusb-0.1.so.4 -> libusb-0.1.so.4.3.0
-rwxr-xr-x    1 root     root        31900 Dec 25 21:10 /usr/local/lib/libusb-0.1.so.4.3.0
-rw-r--r--    1 root     root        29052 Dec 25 21:10 /usr/local/lib/libusb.a
-rwxr-xr-x    1 root     root          710 Dec 25 21:10 /usr/local/lib/libusb.la
lrwxr-xr-x    1 root     root           19 Dec 25 21:10 /usr/local/lib/libusb.so -> libusb-0.1.so.4.3.0
Now the scanner isn't registered in dmesg like it was before when
scanner.ko was a piece of the kernel, not a module.

xsane cannot find it now.

But, this is what I get from the usual suspects.
[root@coyote root]# sane-find-scanner

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x046d, product=0x0900) at libusb:003:005
found USB scanner (vendor=0x1453, product=0x4026) at libusb:003:004
found USB scanner (vendor=0x04b8 [EPSON], product=0x010f [EPSON Scanner 010F]) at libusb:002:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Scanners connected to the parallel port or other proprietary ports can't be
  # detected by this program.
[root@coyote root]# scanimage -L
device `v4l:/dev/video0' is a Noname BT878 video (Hauppauge (bt878)) virtual device
device `v4l:/dev/bttv0' is a Noname BT878 video (Hauppauge (bt878)) virtual device
[root@coyote root]#
So where am I still miss-configured vis-a-vis using

Plz note that the first two items listed above in the
sane-find-scanner output are not scanners, so there is a bit
of ambiguity there.

Cheers, Gene
AMD K6-III@500mhz 320M
Athlon1600XP@1400mhz  512M
99.22% setiathome rank, not too shabby for a WV hillbilly
Yahoo.com attornies please note, additions to this message
by Gene Heskett are:
Copyright 2003 by Maurice Eugene Heskett, all rights reserved.