[sane-devel] libusb doesn't seem to work

Henning Meier-Geinitz henning@meier-geinitz.de
Fri, 26 Dec 2003 10:30:09 +0100


On Thu, Dec 25, 2003 at 11:04:35PM -0500, Gene Heskett wrote:
> I just rebooted to a 2.6.0-mm1 kernel, rebuilt without
> drivers/usb/scanner.
> Its my understanding from copying the mail here that this should
> force the use of libusb since the scanner in the kernel usb stuff
> is being deprecated.

You are right. 

> And, I've tried to install the tar.gz if libusb-0.1.7 but do not
> know if its complete since the make bailed out for lack of
> docbook stuff on this machine.  But a make install immediately
> after didn't bail.  And I ran ldconfig after the install.

That should work. I thought the docbook bug was fixed meanwhile, but
it doesn't matter.

> Now the scanner isn't registered in dmesg like it was before when
> scanner.ko was a piece of the kernel, not a module.

When you plug it in, there should be at least a message about a device
nor bound to any driver. Maybe that depends on the debug level enabled
in the USB system? 

> xsane cannot find it now.

If you have never used libusb before, you must rebuild sane-backends
(and probably the frontends to use it). However, you seem to have done
that or sane was already build with libusb support (see below).

> But, this is what I get from the usual suspects.
> -------------------------------
> [root@coyote root]# sane-find-scanner
>   # No SCSI scanners found. If you expected something different, make sure that
>   # you have loaded a SCSI driver for your SCSI adapter.
> found USB scanner (vendor=0x046d, product=0x0900) at libusb:003:005
> found USB scanner (vendor=0x1453, product=0x4026) at libusb:003:004
> found USB scanner (vendor=0x04b8 [EPSON], product=0x010f [EPSON Scanner 010F]) at libusb:002:002

Looks like sane-backends was built with support for libusb.

> [root@coyote root]# scanimage -L
> device `v4l:/dev/video0' is a Noname BT878 video (Hauppauge (bt878)) virtual device
> device `v4l:/dev/bttv0' is a Noname BT878 video (Hauppauge (bt878)) virtual device
> [root@coyote root]#
> -----------------
> So where am I still miss-configured vis-a-vis using
> libusb?

I'm assumimng you use the plustek backend: Does
"SANE_DEBUG_PLUSTEK=255 scanimage -L" print anything useful? Maybe you
have fixed device files in your plustek.conf (like /dev/usb/scanner0).
Remove them and use automatic configuration.

dll.conf contains "plustek"?

> Plz note that the first two items listed above in the
> sane-find-scanner output are not scanners, so there is a bit
> of ambiguity there.

Which kind of devices are they? sane-find-scanner prints everything
that doesn't identify itsself as printer, disc, keyboard etc. because
there is no "scanner" class.