[sane-devel] HP PSC 2210 not found

David Sumbler david@aeolia.co.uk
Sun, 28 Dec 2003 01:06:14 +0000 (GMT)

On Sun, 28 Dec 2003, Henning Meier-Geinitz wrote:

> On Sat, Dec 27, 2003 at 09:43:02PM +0000, David Sumbler wrote:
> > I run RedHat 8.0, with an HP PSC-2210 USB printer/scanner/copier.
> [...]
> > But I cannot get sane to work (although it used to).  I have now tried
> > removing and re-installing sane (1.0.8), but 'scanimage --list
> > devices' just gives "No scanners were identified." etc.
> 1.0.8 is quite old, 1.0.13 is current. Anyway, that scanner is not
> supported by the SANE distribution but by the external hpoj backend so
> it's the version of that backend that matters.

I installed the latest (hpoj 0.91) yesterday.

> > I modified /etc/xinetd.conf and /etc/services as suggested in 'man
> > saned', and I tried changing both the user and group in
> > /etc/xinetd.conf to 'root' as well.
> You need saned only if you want to scan over the network or if you
> have a parallel port scanner that needs root priviledges otherwise.

The PSC-2210 is USB only.  My network consists (at the moment) only of
my PC and a router, so scanning over the network is not currently

However, I think that possibly some of the cups printing problems that
I was getting until a day or two ago were to do with some confusion
between and (which is the PC's IP address on
the LAN) - maybe something odd going on there.

> "scanimage -L" as root should work even in the case of wrong
> permissions.

No, this doesn't work.

> Does sane-find-scanner find the scanner?


> Is "hpoj" mentioned in dll.conf?

This is /etc/sane.d/dll.conf, right?
Yes - I have the line "hpoj" at the end of the file.

Thanks for your help.