[sane-devel] HP PSC 2210 not found

Henning Meier-Geinitz henning@meier-geinitz.de
Sun, 28 Dec 2003 01:24:28 +0100


On Sat, Dec 27, 2003 at 09:43:02PM +0000, David Sumbler wrote:
> I run RedHat 8.0, with an HP PSC-2210 USB printer/scanner/copier.


> But I cannot get sane to work (although it used to).  I have now tried
> removing and re-installing sane (1.0.8), but 'scanimage --list
> devices' just gives "No scanners were identified." etc.

1.0.8 is quite old, 1.0.13 is current. Anyway, that scanner is not
supported by the SANE distribution but by the external hpoj backend so
it's the version of that backend that matters.

> I modified /etc/xinetd.conf and /etc/services as suggested in 'man
> saned', and I tried changing both the user and group in
> /etc/xinetd.conf to 'root' as well.

You need saned only if you want to scan over the network or if you
have a parallel port scanner that needs root priviledges otherwise.

"scanimage -L" as root should work even in the case of wrong

Does sane-find-scanner find the scanner? Is "hpoj" mentioned in