[Fwd: [sane-devel] saned/Epson problems - ?third try?]

Henning Meier-Geinitz henning@meier-geinitz.de
Thu, 9 Jan 2003 14:28:26 +0100


Hi,

On Tue, Jan 07, 2003 at 09:39:49PM +0100, Lars Tšuber wrote:
> > That's interesting. There is only one change in the net backend
> > between 1.0.7 and 1.0.9 that may cause problems with options. Well, at
> > least theoretically. The new code looks correct for me.
> > 
> > Can you test xsane 0.90 with net client 1.0.7 or vice versa? So we
> > could find out if the difference is xsane or the net client.
> 
>             xsane 0.80  xsane 0.90
> sane 1.0.7  works       does not work (see below)
> sane 1.0.9  works       does not work

If you can reproduce the problem with net client 1.0.7 (using xsane
0.90) that means that the problem isn't caused by the changes from
SANE 1.0.7 to 1.0.9.

> i installed xsane 0.80 on the client with sane 1.0.9 and it worked then
> i installed xsane 0.90 again and it worked too.
> after quitting and restarting xsane it didn't work again!
> only deleting ~/.sane/xsane has not the effect like installing and
> running xsane 0.80 before xsane 0.90.
> so i played a bit with the settings under xsane. xsane 0.90 works under
> special circumstances:
> 
> when you change the 'drop out' in 'binary' mode you can switch to
> 'color' afterwards
> when you change the 'bit depth' in 'color' mode (when you are in color
> mode at startup) you can change other settings too.
> that is a bit confusing to me, because i see no reason for this
> behaviour.

Looks like a backend problem (maybe with interference of the frontend)
to me now.

I don't think the net stuff is involved, it seems to only trigger the
bug(s). But it's really difficult to debug from here.

Maybe the backend author has more ideas :-)

> by the way is it a sane limitation or a sane-driver limitation that i
> can't scan with 4800 dpi resolution, 
> because the scanner is able to do a scan with 2400x4800 dpi physically?
 
Such things depend on the backend.

Bye,
  Henning