[sane-devel] Scan over network hangs

Robin Rosenberg robin.rosenberg@dewire.com
Thu, 9 Jan 2003 20:56:02 +0100

onsdagen den 8 januari 2003 14.48 skrev Henning Meier-Geinitz:
> Hi,
> On Wed, Jan 08, 2003 at 03:34:33PM +0100, Robin Rosenberg wrote:
> > I have an Acer 620ST (scsi) that works fine when scanning locally using
> > the snapscan driver, but when doing a scan over the network it always
> > hangs. The scanner head move a little bit, but then halts.
> >
> > I'm using Mandrake 9.0 (kernel and these versions of sane.
> >
> > 	libsane1-1.0.8-5mdk
> > 	xsane-0.87-1mdk
> > 	sane-backends-1.0.8-5mdk
> >
> > I've tried sane 1.0.9 also on both sides, but that didn't change
> > anything.
> Check that you don't use a firewall or NAT setup that blocks the SANE
> data port.
No, with that I wouldn't be able to get hold of the scanner.

> Please try other frontends (xscanimage, scanimage). Does the same
> happen?
Yes, (or did, see below).

> Please try other backends (e.g. the test backend: xsane net:hostname:test).
> If you scan using the net backend on the server, does it also hang?
> --> e.g.  scanimage -d net:localhost:snapscan:/dev/scanner
> Check the logs. On the client side, you can set the environment
> variable SANE_DEBUG_NET=255. On the server side, have a lokk at syslog
> messages.
> For more debugging on the server side, disabled saned in (x)inetd.conf
> and start it manually like this:
> saned -d255

I've added the debug variables, and guess. I did a successful preview and a
failed scan where the whole server hung until I reset the scanner after which
I had to reboot the machine since ths SCSI driver was locked by something

However any attempt to repeat this failed. I retried previews using the same
settings (-d255) and I got to see most of the image and then the preview window
was cleared. Consistently dozens of times, but no hanging.

Then I lowered the debug level to 10. No change. And  then to 1. Success. Even
scanning worked for the dozen times I tried. Then I removed the debug flags, and
enabled the sane daemon through xinetd again. Everything still worked.

And then I coldbooted to see if that would repeat the problems, but no. It just works. 

I'm puzzled, wrong phase of the moon?.. but I don't think it changed during last evening.

Xsane is great when it works though. 

-- robin